Trying to copy files from MP3 player to PC, no success

I have a Sansa Clip+ which is about 8 years old. It is still working fine as a standalone MP3 player. There are some music files on there which I don’t have anywhere else and which I would really like to copy over to my laptop. The laptop is running Windows 10 but says it’s up to date with all required updates.

When I connect it up via a USB cable, the screen on the MP3 player changes to say “Connnected” and I get a pop-up wndows explorer window on my laptop which shows me This PC > Sansa Clip+ 8GB > Internal Memory. 2.8 GB free of 7.35 GB. Great :slight_smile:

However, when I click onto this folder to expand it, everything goes really really slow. Sits there for several minutes with a whirling circle before it tells me that there are a couple of sub-folders called “Music” and “Podcasts”. Trying to expand the “Music” folder means another several minutes of waiting before again it starts showing me subfolders named after artists.

I’ve tried leaving it for a couple of hours; this leads to it showing a list of files, each with a padlock symbol, no filenames, no filesizes.

I’ve tried dragging folders over from the MP3 player into Windows without opening them, but it just drags over an empty folder.

I’ve tried changing the USB connection setting on the MP3 player from Auto to MSC but when I do this, the MP3 player says “Connected” when I plug it in but the laptop doesn’t show it in Windows Explorer at all.

I’m nervous to try resetting anything on the MP3 player in case I lose the files.

I’m hoping that there are still some users on this forum who might be able to help … fingers crossed…

Take a look at the replies to this similar question from 2013. There is a lot of advice and back and forth. Take a look at the comments from “black_rectangle”. Maybe reply here if you have success and let us know about your solution.

Thank you so much for this.

Update: I actually found a fix without trying to :grin: I changed the upload setting to MSC and tried plugging it in, nothing showing on the PC side. Then I left it plugged in while I did some more searching and when I went back to Windows Explorer, I could see all of my files. It seems like it just needed a little time to connect and process. I was then able to download the files I needed without any problems.

Just wanted to post this update in case it helps anyone else. And thank you dfeld2005 for helping me out