Please Help! 2GB Sansa Clip not being picked up by computer...cant import/export anything.

Hi everyone,
I found this site as I was searching for an answer to my USB question.  Here’s my situation:  I have a tiny 2GB Sansa Sandisk MP3 player.  I bought it about 4 months ago.  It came with a set-up CD, and a free trial of Rhapsody (which I soon removed because once the free trail expired, it wouldnt allow my seperate/non-rhapsody songs to play either).
Usually, I would plug the USB cord into a computer, and a message would pop up asking me what program I wanted to open the MP3 files with.  But the few times that I’ve tried connecting it to a computer in the past couple of months, NOTHING pops up.  Those were library computers, so that could have been due to some kind restrictions (although, months ago it did show up when I plugged it into a library computer).  I now have my own laptop (just bought it 2 days ago) and noticed the same thing is happening.  And I did go to “Start” then “Computer” where the C: Drive, D: Drive, etc are…which is where I would usually see “Sansa MP3 Player” but it’s not there.  Since this has occured on more than just 1 computer, Im thinking maybe the issue is within the MP3 player, not the computers…but is it?  By the way, I did try turning the MP3 player on and off while it was plugged into the computer, using each of the USB ports, and playing and stopping MP3 player songs, but that did absolutely nothing.  I’ve been in the Device Manager Drives section of my computer…it shows Keyboard, Mouse, USB, and tons of other stuff.  I went to each of the like 10 USB icons shown and it said its working properly and that all 4 are free, although 1 IS occupied by my MP3 player.  I tried updating a couple of drives (though I dont know squat about “drives” so I probably shouldnt be messing with it. lol) and the computer processed for a bit, then said “You already have the most updated version” or something. I called Sansa but the guy wasnt able to fix the problem.  He and I tried several avenues.  One of which was to push the lever up (to power it on) while pressing the middle button down and plugging the USB into the computer - nothing changed.  My laptop is a Dell I1525-121B and has Windows Vista and Windows Media Player (and I found out today…Media Center and Media Direct…3 medias?!  But its okay…watching videos/DVDs is what I do most on it anyway right now)  Tried using the “Sync Device” section of the player but it was blank-showing “Connect a device”.  If anyone knows how I can get the computer to acknowledge the presence of the MP3 player, I’d really appreciate your input.  I’ve tried to give detailed information to help facilitate a correct answer.  *Im barely up with technology, so just dont shoot back a bunch of codes or techy abbreviations.  lol  Thanks so much you guys!

~Shev

Message Edited by shev on 10-16-2008 06:24 PM

Message Edited by shev on 10-16-2008 06:28 PM

Try checking your mode setting (in the Settings menu). Go into settings and look for USB Mode, if you don’t have it, you may have an older version of the firmware and will need to update it. If you do have USB Mode in settings check to see what it’s set to. Put it into the MTP mode making sure that you select it and connect it to your computer. If that doesn’t work, put it in MSC and see if the computer detects it.  If it works in MSC, you’ll have to drag and drop music from your Music folder on the computer to the Music folder in the clip. If it works in MTP you’ll be able to use Windows Media Player to transfer music.  If you still have problems with both of the modes (you’ll have a third mode called Auto-detect, usually doesn’t work with Vista) you may need to format the player and start clean. There is a Format function in Settings, it will remove all of your music files so make sure you have them backed up. After formatting try it on your computer again.

Hi,

Thanks a lot for taking a moment to give me some advice.

I guess I forgot to mention, I had already tried changing the MP3 player’s 3 USB Modes : Auto-Detect (which is what worked months ago on other computers - it would show up in the My Computer section and I could easily delete or drag/drop in files), MTP, and MSC.  I considered doing Format, but I was like “Umm…I think that might erase everything” so I didnt do it.  Based on what you said, I was right.  lol  I really dont want to lose my songs and stuff.  But if I must, I will…if its a guarantee that it’ll fix the problem.  Otherwise it would be for nothing.

*Oh, I did try to install new “firmware” that I saw on this site (have no idea what it does…I guess it modifies the player’s compatibility settings so that it works with the latest computer technology?) but in order to place it inside the player, it would have to be Showing Up in the computer, and its not…so I downloaded it but couldnt do anything with it.

Long shot, but … try a different USB cable.

Yeah, cuz im pretty sure its good (especially since the player charges when the USB is plugged in).  But, its worth a try.  I’ll let you know.  Thanks!

I believe that the power is carried over different lines than the sync data, so in theory a cable could do one and not the other.  But I’m no expert, I could be wrong.