Troubleshooting my Sandisk disk to see if it is dead

Hi all, thanks for letting me sign up with you. I’m not very computer literate so fingers crossed I get this right.

2 years ago almost to the day I bought a ‘bare bones’ computer and a friend of my took some parts from my old computer and put it in the new computer. The new computer came with a Sandisk 128GB SSD drive system. On the black label it says “Solid State Drive” and has a line underneath and in red says “SanDisk”. The white label has more information:

Capacity 128GB


LBA 250,069,680


SN 131846400739

WWN 5001B449BE3D66E3

It has a bunch of other stuff. Luckily I use Easeus Free to back up things. What happened is the SanDisk system suddenly stopped and Windows wouldn’t work. I can’t remember exactly but it said something like, “Disk read error. Cannot boot disk” in a dos system - it was a few weeks ago.

I tried everything but still couldn’t get Windows up and going. My neighbour come around and bought some other disk and installed it for me, and didn’t know why the Sandisk wouldn’t work.

So what we’re seeing is this.

When he booted up the computer with the new SSD with Windows installed, all is fine. It picked up the old SandDisk in Start-Control Panel-Device Manager, I can see it says Sandisk 128GB there, all the numbers are right. The BIOS system also says its installed. When he went to My Computer, the disk isn’t there. When he went to the Administrative Tools-Computer Management-Storage-Disk Management, the disk didn’t show up.

He suggested updating the Sandisk firmware or replacing it with an original version, and installed SanDisk SSD Dashboard, but the summary is follows:

He could see the SandDisk in:

  • Bios

  • Device Manager

but not in

  • Administrative Storeage in computer management

  • Sandisk SSD dashboard

So I’m confused whether it’s dead or not. It seems like it’s there, but it’s not there. He took it away and tried it on  a Linix Ubundu and it wouldn’t recognise it, said to run diskcheck/f or something (we can’t remember exactly) but he reckons it would only work it we knew the drive letter, and we can’t get the drive letter because it’s not recognised in Windows Admin tools.

I’m confused. It’d be good to see if we can resurrect this piece of hardware. I’ve got an external SATA and lead configuration to test it with any solutions, or he can open up the computer and mess around with the leads.

Does anybody have any further ideas to see if this Sandisk can be resurrected?

this sounds like a bad SSD. Weird it still is showing in the BIOS but if it is not showing in the admin tools there probably is not a lot you can do with it. Contact sandisk support if it is 2 years old it should still be covered by the warranty. 

I’m never buying Sandisk again: found my receipt and went to fill out the warranty claim form and my country isn’t supported!

I don’t think any manufacturer should sell any product in any country declaring a warranty, when one can’t claim the warranty because the country is ‘unsupported’. Very annoyed (Australia: warranty claim page here

However, thanks for replying. I’ll write to them see what they say, and then contact my local Consumer Affairs.

Edit: the above link is correct but doesn’t work when clicking on it. To get to the page you can also go to then on the right, click ‘Request Replacement’

SanDisk only support specific countries for online RMA processing. You can still email, call, or chat them and they will take care of you.  

You’re absolutely right drlucky. I contacted them and they gave me the process to forward it to an Australian address. Shame I bought another SSD for the computer - alhough my laptop could do with an upgrade!! Yes, thanks for letting me know all this information you’ve been more than helpful.