Sub Folders are Gone. Help restore!

I formatted my Sansa Clip (4gb).  Now the sub folders are gone. i can still add music and it still works, but all the songs go into one folder and I can not search by artist, song, album, etc.  I’ve opened up my sansa updater, but I don’t  know how to redownload another firmware…or if that is the solution.  Any suggstions on how to restore the folder settings so I can organize my music??

Would the “one folder” that all your music is in be listed as “Unknown” in the Clip’s music menu? The Clip doesn’t organize music by folder, it organizes them by ID3 tags (text data embedded in the audio files). If all your tracks are lumped under “unknown”, it means the ID3 tag data is missing/incomplete. There are a number of programs you can use to edit the tags (including basic editing capabilities built right into Windows), but perhaps the best is MP3Tag.

By the way, there are different versions of ID3. The version that works best with Sansas is ID3v2.3 ISO 8859-1. You can set MP3Tag to write your tags in this format. Other tagging programs may or may not support that version.

Formatting the Clip clears the data area in memory, but does not affect the operating system of your device.  The processor and system will automatically rebuild these folders for you.

On the device, first use the resident Format function, under Settings > System Settings > Format > Yes to clear everything out.

After disconnect, and cycling the power, the sansa will rebuild the file structure (folders).

Bob  :smileyvery-happy:

Actually, yes, it is “unknown”. I will try your sollution and report back. 

Thanks!!!

Hi,

Could you do me a favor and walk me through the MP3tag program. You mentioned I should set it to " ID3v2.3 ISO 8859-1"

I’m fairly competint with this sort of stuff, but I can’t find anywhere to make this change. 

I do have different tags: FLAC, ID3V1, ID3v2.2, ID3v2.3, and WMA.  Is this what I need to change? If so, how do I do that?

Thanks for helping. 

In Mp3tag go to Tools > Options… > Tags > Mpeg:

The “Write” box on the right has the settings you’re looking for.

Next you’d need to load your MP3 files into the program (e.g. drag and drop them from Windows’ Explorer into the white, empty file list area). Check the “Title”, “Artist” and “Album” columns to see if proper metadata is present at all. If it is, check the “Tag” column, which will tell you the tag format. For MP3 files you want it to read “ID3v2.3” (this does not tell you the character encoding - ISO-8859-1 vs. UTF-16 - used, however). If the tags are there but the wrong format, select all files (CTRL+A) and click the floppy disk icon in the toolbar. This will re-save the existing tags in the format you’ve chosen in the settings.

Just for the record, with MP3 files I’m using the default ID3v2.3 UTF-16 and my Clip+ has no problems reading this format. It does NOT like (and will truncate or ignore) ID3v2.4 UTF-8.

FLAC and WMA files each use their own tagging format as far as I know, if you are sure these files have proper tags and the player still won’t show them, something else may be broken. Resetting the player or reinstalling the firmware may be worth a try in that case.

                       

Hi,

Thank you so much for the help. It did not work. My folders are still in the “unknown” folder. I will try to reinstall the firmware and then do it all again. I will let you know. Thank you though.

Very helpful!

If the tunes are showing up on the Clip as Unknown, it is because the ID3 tags for the tune files, for the categories such as Album, Artist, Track name, and Genre, are not filled in. 

MP3Tag, as well as Windows (right click on the file(s), choose Properties, and go to the ID3 tag screen (in different locations with different Windows versions–with Windows 7, for example, under the Details tab)), can be used to fill in the ID3 tags.

Despite the nice screen shot of the MP3Tag Tools settings above, your Sansa player is looking for the format ID3v2.3 ISO-8859-1.

If you’re using MSC mode, you should be able to change and save the new tags with the files on the player. However, if you’re using MTP mode, you’ll have to make the changes to the files while they are on your computer and then re-transfer them back to the player.

That was it!!!

I changed the setting to MSC and it fixed it. Nearly all my tags were correct. Some were not, but that alone did not fix the problem. When I switched to MSC, it subdived my music into the artist folders.  Perfect!! Thanks to everyone’s comments!!

MSC = Mode of Sansa Champions :smiley:

@tapeworm wrote:

MSC = Mode of Sansa Champions :smiley:

@jamieson wrote:

 


@tapeworm wrote:

MSC = Mode of Sansa Champions :smiley:


 

+1