Clip no longer reads ID3 tags


I am the owner of both a 4GB and an 8GB Sansa Clip.  I’ve had the 4GB version for well over a year and I’ve always used Winamp as my PC audio software of choice.  All of my MP3s have ID3 v.1 tags and until recently, the Clip was able to read them.  Then all of a sudden one day, everything went into the “unknown” category which is unacceptable.  I can’t think of anything that changed.  I never upgraded the Sansa firmware version or changed my ID3 tags for my music.  I never upgraded my version of Winamp either, but just for kicks I did upgrade to the latest version and the problem persists.  I’m also have the exact same problem with a brand new 8GB clip that I just bought last week.  Nothing I try is working.  Can anyone help???  Thanks.


The tag format of choice for all the Sansa players (particularly the newer ones) is ID3v2.3 ISO 8859-1 , not v.1 as you’re using. Some of the older ones would read the v.1 tags and I don’t know why yours did at one time, but is refusing to do so now, but you should update them to the newer tag format to avoid any future issues.

MP3TAG, a free program will make quick work of this. Some people have success editing the tags with the files on the playe, while others recommend that you edit the files on your computer, delete the ones on your player, and re-transfer them over.

Thanks for your response.  Unfortunately I’ve tried this and the player still will not recognize the tags.  Some of my files were even detected as being ID3v.2.3 already. This is really getting frustrating…any other thoughts?

The only other thing I could suggest is to format the player and re-load the songs. Although a drastic move, it might help for whatever reason.

I’ve already tried that also.  Is there another music player other than Winamp someone could suggest?  I prefer not to use Windows media player.

You also might want to delete the earlier version ID3 tags, when you convert to the current version–with some players, having both can cause issues. 

As does Tapeworm, I’m at a loss as to why your player decided to quit recognizing that which it once recognized. I would use mp3tag to set and verify the tags, regardless of your problem, this is my preferred software for this purpose. Use drag and drop in MSC mode to load music, it’s generally agreed this mode leads to the least problems unless you are using protected music.

I finally figured it out.  I set the player to use MSC mode instead of autodetect, dragged and dropped my files into the music folder and WALA.  Thanks for all the help everyone!