Stuck on "refreshing..."Have formatted,removed SD card...I`m going nuts

Ideas Boys?I tried pulling the power halfway thru the boot too.

Don`t know what else to do.Help please.

How did you format? If you can make a computer connection format it again to FAT32.

Last night I formated in window 7 explorer.

Win 7 recognized my device [Fuze]

Still stuck on “Refrshing…”

Now,have restarted multiple times.

Error message “USB DEvice Not Recognized”

Have tried holding wheek at 12 o`**bleep**

and 9 o`clock.

Stuck on  grey screen/USB not recognized.

Ideas please?

BTW,thanks for your service.I am a PC tech {Fubar Mobile PC] as well…Otis

If it’s entering (and stuck on) “Refreshing Database” it must still be reading something in the database. On a completely blank machine, it would not go into the ‘refreshing’ mode. Formatting would completely erase what has been stored in the memory. I’m thinking that however you formatted it, it didn’t complete the format properly.

Have you tried placing the power switch on the side on HOLD (in the down position), then pressing the REW |<< (9 o’clock) button while plugging it into your computer? It’s important to continue to hold the REW button until it pops up in Windows Explorer. This should force an MSC connection so it can be formatted. Do you have access to an XP machine? I don’t know how it works in Win 7 but in XP, you can right click on the player’s icon (note that there will be 2; one for the player and the other will be the card slot) and select Format… make sure it formats it as FAT32 and do not use the Quick Format option.


Jeez…tx…you know,I can`t swear that I never unplugged when tranfer was not yet complete.

Think tyhis is what cause this corruption?

@otis48 wrote:



Jeez…tx…you know,I can`t swear that I never unplugged when tranfer was not yet complete.

Think tyhis is what cause this corruption?

Very well could be. :wink:

Well,I certainly appreciate your ideas anjd knowlege.

I`m on my 3rd go round of the internal disk cleanup you descibed.

The question is,how do i have to get files [mps] onto thids thing without

neccesstating this procedeure?>

Never had to do all thids before-I just moved things aroind in

windows explorer [Win 7]

What happened and what do I have to do?

Sunday 6pm

1]Hung on refresh…"

2]Started w/hold down/rewind.Screen says “no disc…please insert”


 None seem to do anything

4]Nothing present in windows explorer [Win7]

5]Screen says “Connected”

6]Tried #3 again

7]Cancel works

8]Explorer show drive H: [not Sandisc] with 3.45 of 3.66 free

9]Tried #3 Screen disappears

10]Explorer show Drive H; with empty media files [music,audio books,etc]

11]Moved mp3 album to H;/music



This has taken HOURS.Way too much.

Seems like crappy OS to me.


Force the mp3 connection with the Hold button, etc. If the Fuze was set to Auto Detect, and it detects Windows Media Player on your computer,  it will connect in MTP mode as a virtual device. Your computer can only see MTP or MSC, not both. This may be part of the problem until you get the Fuze going and make it only use MSC (Settings/System Settings/USB Mode).

You could try reloading the firmware. There’s a firmware update thread with links to the final Fuze firmware.

Don’t use the updater. Download the firmware itself from the All Regions links. There are two versions–the Fuze was made as two different pieces of hardware. If you can look around at the Fuze while connected, look for version.sdk (or possibly version.txt). Open it with Notepad and you can see if your firmware starts with 1 or 2.

If you don’t know which yours is, just download both of them and try them

Unzip the downloaded firmware. You’ll see FuzeA.bin for version 1 and FuzeP.bin (I think, not sure) for Version 2.

Make the connection. Drag the .bin file onto the driveletter. Disconnect and it should update firmware. If you haven’t been able to find out which firmware version is correct, and it won’t update, try the other version.

Has the album worked before on the Fuze? There could be some garbage in the tags, and the Fuze firmware is finicky about tags.  Giant graphics or huge comments can slow down Refresh. 

You can look at the tags, and fix them,  with mp3tag,

Under Tools/Options/Tags/Mpeg set its Write default to ID3v2.3 ISO-8859-1.

Highlight tags to look at them. Look at Comments–you can <blank> them.

If the album graphic pops up when you highlight a tag, it’s embedded.

Under View/Extended tags you can extract the graphics. The floppy disc icon (on the right) will make a copy of the graphic called folder.XXX (.jpg, .bmp., .png). The X under the floppy will extract the images from the tags. 

I run every album through mp3tag before putting it on the Fuze. Just highlighting all and Save will make the tags the correct version. I extract the art if someone jammed it in there. Under Tools, there’s also Auto-Numbering Wizard with Leading Zeros, which is also helpful.


Product: Fuze
FW: V02.03.33A
Region: Americas

Also have




And the default folders.

They are empty

Still stuck on refrersh…

So it’s a v2.  That’s the latest firmware, but it may have gotten corrupted, so it’s still worth trying a firmware reload. And since you can see those files, you might try formatting again to FAT32. Sometimes it takes a couple of tries.

Remember,  your computer can only see one USB mode at a time. Something else may still be stuck in there from MTP mode–though the format should have removed it. 

Can you connect without forcing the connection and look around? Try opening Windows Media Player before you connect, and maybe you can get past that USB Device Not Recognized.

Also, if you’re comfortable monkeying around in Device Manager, you could take a look in there after trying to connect, and uninstall if you see the exclamation point on a USB port. Reboot should reinstall your USB port and possibly fix things.