Refreshing Media Screen is Stuck

Whenever I Plug My 4GB Sansa Fuze into the Computer to charge, once I unplug it, it tries to “Refresh Media”. But it always gets stuck. If I press Deauthorize or License a couple times It usually works, and it doesn’t try to Refresh Media, but the last couple times I tried that, it didn’t work. And it’s not just after I put new songs onto it, It’s every time I plug it into the Computer.

Check your ID3 tags. It could be choking on something it can’t read. A good thing to download (it’s free) is MP3TAG. Set the default Write format in the Tools menu to ID3v2.3 ISO-8859-1 for best results. You can edit and/or change a folder at a time. If they’re the wrong format as they are now, simply re-saving them (after changing the settings) will change the format, and may solve your problem.

Well, I downloaded MP3Tag, and changed the Write format to ID3v2.3 ISO-8859-1. But now when I Try to Access my Sansa to edit or change the folders, it doesn’t show up. Before I changed the Write format, it did show up, so I know the computer recognizes it, I just can’t Access it. Any ideas?

@kniss wrote:

Well, I downloaded MP3Tag, and changed the Write format to ID3v2.3 ISO-8859-1. But now when I Try to Access my Sansa to edit or change the folders, it doesn’t show up. Before I changed the Write format, it did show up, so I know the computer recognizes it, I just can’t Access it. Any ideas?

Whatever your USB mode is, change it to the other setting (NOT Auto Defect).

Wow, I plugged it into the computer and tried messing around with it in MP3tag, but to no avail. Then,when I unplugged it, it turned on and didn’t try to refresh media. I turned it off and on a couple times and it still worked. I have a feeling though, that next time I plug it into the computer, I won’t be so lucky…

It gets stuck on Refreshing Media when it runs into a tag it doesn’t like. Fixing the tags with mp3tag  usually fixes that problem.

There are two USB modes, MSC and MTP (Settings/System Settings/USB Mode), to transfer files onto the unit. You computer can only see files transferred in the mode the unit is using–if you sent files in MSC, and the unit is on MTP, your computer won’t see them.The Fuze itself sees everything sent in both modes.

MTP is to sync and do playlists, etc. with Windows Media Player, though you can also do drag-and-drop with it.  MSC makes the unit look like any other disc drive to your computer and is the more straightforward connection. I use MSC. 

With MSC, the Refresh Media starts every time you have changed anything on the unit after you disconnect.  With MTP, I believe the unit is refreshed before you disconnect. But MTP does things like changing folder names , which drives some people nuts.

So pick one mode and stick to it. If your current one is working and making you happy, keep it.

I Tried Changing it from MTP to MSC, Which I’ve done before when there’s been other problems with my Sansa. For some reason, whenever I plug my Sansa into the computer and go onto Rhapsody, and it’s set on MSC, it calls the Sansa SANSA FUZE in all caps, and calls my Memory Card K:. Is that a problem? Just wondering. Also, maybe a month ago, I tried adding a batch of 5 songs to my Sansa, but it was already screwed up at that point, and couldn’t refresh media. I thought it might have something to do with those songs, so I tried fixing the tags on them. On one of the songs, it doesn’t show any information, and when I try to save the tag, it says “File K:\MUSIC\Music\Bruce Dickinson\4EE10100_The Best Of Bruce Dickinson\ cannot be accessed”. Then when I Try to Delete it, it says “Cannot delete the selected files!”. Finally, just one more thing. I’m a guitar player, so I used to use my player to learn songs. But recently when I would try to rewind the song, it would try to refresh media and then get stuck. I think that was where it started to mess up. Hope this was of some help.

When the mode is changed, the computer sees the Fuze differently. MSC sees the Fuze and the memory card slot as two different disc drives (I assume J: and K: ) , so that’s OK.

The Bruce Dickinson song is likely to be a corrupt file.  Maybe WIndows likes Iron Maiden better than the solo stuff. (joke).

Windows might be able to fix it or delete it. Put the unit in MSC mode, connect, right-click on K: and go to Properties/Tools/Error-checking and run that. It may ask you if you want to “save bad chains”–don’t, since that’s the junk that’s messing things up.  (Leave the chains to Iron Maiden.)

From the folder name 4EE10100_etc., that looks like you added it in MTP, which in turn added the extra gibberish to the folder name for its own mysterious classification system. So if Error-checking doesn’t find anything in MSC, switch to MTP and use Windows Explorer on the Fuze until you can see the K: drive, then run Properties/Tools/Error-Checking in that mode.  I can’t give you exact steps to do this because I don’t use MTP.

Meanwhile, the rewind situation. One of the mechanical problems of the Fuze design is that the rewind button is right on top of the microSD card slot.

After some use on the Fuze, you end up slightly loosening the card if you mash down on the << side of the wheel, and so it refreshes because it thinks you might have inserted  a new card. This happens on my old Fuze, too. The only workaround is to be careful to press on the inside edge of the wheel–use a fingernail or something. 

But when the refresh gets stuck, that’s your bad file.

Well, last night I tried taking the SD card out, and wouldn’t you know it, it skipped the refreshing media screen.(Guess I should have tried that earlier.) But now i don’t have the 300 songs on my SD card. Anyway, I tried going to Properties/Tools/Error-checking, but when I try to run it, it says "Windows can’t check the disc while it’s in use.

Do you want to check for hard disk errors next time you start your computer?" I don’t want to screw up my computer or Sansa, (Well, I don’t want to screw it up even more.)So what should I do? Oh, and for the record, I like Iron Maiden better than Bruce Dickinson too.

Just fooling around on the Maiden stuff.

Have you put the unit in MSC mode (Settings/System Settings/USB Mode) before you use  Error-Checking? I’ve never gotten that message.

Yes, I’m positive it’s set on MSC. I’ll try again later. Right now there’s another sansa plugged into the computer.

Yep. Plugged it in, tried doing it again and got the exact same message.

With the unit set in MSC, you’ll need to use Error-Checking twice: on both the Fuze internal memory (J: ) and the card (K; ).

It’s just odd that the computer thinks the card is in use.

 Maybe something is hooking up to the card and preventing you from Error-Checking it.

Try this: Right-click on the card, Properties, AutoPlay tab, and go through ALL  of the drop-downs–Music, Pictures, etc., and choose Take No Action and Apply.

 Then disconnect and reconnect, and see if you can run Error-Checking now that AutoPlay is off.

You could also, as a further resort, just erase everything on the card (assuming you have copies on your computer) by formatting it from the computer if you can get it recognized: K:, right-click, Format to FAT32.

Then run each album through mp3tag set to Write  ID3v2.3 ISO-8859-1.  I hope you allowed mp3tag to add itself to context menus when you installed it. If you did, right-clicking on an album folder should list mp3tag among the options. If not, open mp3tag and Open and browse to  navigate to where the album folder is and open it.

Then highlight all the files. To make them extra-Fuze friendly, make sure they are running in track order, top to bottom, and hit Tools/Auto-Numbering Wizard with Leading Zeroes checked. This will make the track numbers 01, 02, etc.–and, bonus, save the tags to your Write format, ID3v2.3 ISO-8859-1.

Put that copy of the album back on the Fuze or the card, and you shouldn’t have any Refreshing  Your Media hangups.

I once had a mysterious incident with my own Fuze, when inserting the card just stopped it dead. The card was fine in another reader, and I always run albums through mp3tag/Auto-Numbering/ID3v2.3 before they go on the card.

But after I tried a number of things, what worked was to Format the unit itself from its own menu.

Don’t ask me why. It makes no sense. But it worked. Of course, you will have to reload all your music back on the Fuze afterward,  which is time-consuming, so I think it’s worth trying these other steps first.

First off, I’m very sorry for not replying sooner. I guess it was just because I had spent so long trying to figure out what was wrong with my Sansa, that I just needed a little break. However, I don’t think my Sansa will ever be fixed. I’ve been using it for the past month or so without the memory card, and it worked just fine. Then, one day when I was listening to it, I got that message “your subscription tracks will expire in 3 days.” I forgot about it until after my subscription tracks had expired. So I plugged it into the computer, and due to a combination of several problems with my Fuze, It no longer says that it is a Rhapsody compatible device, which meant that I couldn’t renew the subscription tracks. I unplugged it, turned it off and then when I tried turning it back on, I got the dreaded refreshing media screen, and like before, it froze. With or without my card in the Sansa, it just won’t turn on. And while I could try to figure out this problem too, I think I’ll just get a new Fuze. I know that I could try reformatting, But I was actually looking for a 8gb Fuze in the first place, but if i remember correctly, They didn’t have any 8gb’s so I just got the 4 gb Fuze, and I would like to put more music on it. So, thank you very much to everybody who tried to help me with this problem. I would have been lost without all of your help.