SSD not detectable


I’ve bougth the 240GB SanDisk SSD a month ago for my Lenovo L520 laptop.

After I’ve copied win7 and data from my old hdd for some days everything worked well.

Then I’ve got “Operating System not found” error on booting.

Even in an external usb case the ssd was not recognised…

I’ve send it back and the shop run some tests. They said everything was working well and send me the ssd back.

It seems the ssd was empty again ( erased after tests they said) and I was able to install linux on it.

Its now one week past and i’ve deleted all linux partitions and installed windows 7 ( clean install).

After installing all microsoft updates i get “Boot device not found”; again!

I’ve tried to boot linux from usb stick and I see that bios doesnt recognise the SSD.

F12 ( Boot Device selection ) doesnt shows the device also.

Some Idea whats wrong??


Lenovo L520, 8GB, SATA AHCI Mode enabled

There’s a difference between “Operating System not found” and “Boot device not found”.  With the first a file like the bootmgr file could be missing, with the second the BIOS isn’t configured to look at the SSD before the HDD. 

And depending on the system the BIOS may have to be tricked into finding the removable device.  On my netbook I had to make my USB drive the 2nd removable device before the machine would accept it.  USB Floppy, USB SanDisk, HDD.

I wonder if they returned you another drive…As my 120GB drive died in a fujitsu latptop…and wouldnt work anymore…not even on another pc.  I bought a 2nd one before the 1st one failed.  Now my 2nd one is dead. :(  I haven’t tried another pc/laptop because it was just like the previous one.  It went to sleep…then came up where the laptop couldn’t see the drive anymore.

Operating System not found” -  There’s a problem with the OS installation

 “Boot device not found”.          - There’s a problem with the Hard Disk. 

Shed me a light on this please. Is there an SSD with 240GB capacity? I think he meant HDD. If it’s boot device not found, it could be that those cables are just loose and unplgu/replug those cables will sort this out for you. 

"Is there an SSD with 240GB capacity?"

Google is your friend.  :wink:

I replaced hd in my fujitsu laptop with my recently purchased sandisk SSD (120G) . It worked fine on the first day and went dead completely on the second day. The SDD drive is completely undetectable either used as external drive or internal drive. The drive is totally useless now. What a terrible manufacture error!

I had success getting my data (my precious data!) off of a busted Sandisk Ultra SSD.  I detailed how inthis post.

Hope that helps, though I realize its a little late.