Sound very quiet despite turned up to maximum

Is there any other setting that I can adjust?

You should have a HIGH & NORMAL volume range setting in Settings > System Settings > Volume. If you don’t you most likely have your Region set (when you first started up your player from out of the box) to Europe. There is an EU-mandated volume cap or restriction is place that limits the volume to 80db, I believe.

If you reset your Factory Settings, it will ask you again to select your Region. Choose either North America or Rest Of World to bypass this ‘legality’ and get your HIGH volume back.

Also, to isolate the issue further, does it happen on all mp3s? What file format are you using?