Songs that I have rights to won't play

When I load songs to my Clip+ a lot of them won’t play.  Twice I’ve deleted everything, reripped the files as MP3s, and reloaded them.  Both times it happened again - but it’s not always the same songs.  I can’t figure out what the difference is.  It’s happening with songs I downloaded from Amazon.com as well as with songs I ripped from CDs that I own.  When I look at the file information on my computer, all the songs appear to be identical in format.  I removed all extraneous characters from the file names.  The only thing that sets the songs apart is that when they come up on the display of the player there’s an underscore in front of the file name.  Like “._Song 2”  But that doesn’t show up when I connect the player to the computer and look at the songs in the music file, so I can’t identify the songs.

All I want is for my player to have only files it will actually play on it for when I workout. Any ideas why this is happening and how to fix it?

are you using a MAC to load the songs? if so the files that start with ._  are created by the MAC when it writes to a DOS file system. There is not much you can do to avoid having these files copied and they are a nuisance since the clip will freeze if it tries to play one of these files. If you have a PC set it to show hidden files and folders and connect the clip and delete the files that start with a ._ (note that these are not actually songs just files used by finder for indexing) if all you ahve is a MAC then you may need a program that will copy the files for you. do a google search for kopymac. it is a program that will copy the files without the ._  

Yes, it is a Mac.  So does this mean that all the songs will play, but some of them have duplicate ._ files? 

I’ll check out kopymac, anyway.  Thanks.

yes, that is correct. 

kopymac is probably the easiest  way but if you are comfortable with terminal you can try this as well. 

There is a command called dot_clean that can be used to cleanup the dot-underscore files after those files are already moved to the externalstorage. (dot_clean /path/storage/)

There is also a Terminal command to prevent the .DS_Store to be created as well.

   1.  Open Terminal.

   2. Execute this command:

      defaults write com.apple.desktopservices DSDontWriteNetworkStores true

   3. Either restart the computer or log out and back in to the user account.

If you want to prevent .DS_Store file creation for other users on the same computer, log in to each user account and perform the steps above—or distribute a copy of the newly modified com.apple.desktopservices.plist file to the ~/Library/Preferences folder ofother user accounts. 

Message Edited by drlucky on 07-28-2010 02:07 PM

Message Edited by drlucky on 08-12-2010 05:07 PM

"There is also a Terminal command to prevent the .DS_Store to be created as well.

   1.  Open Terminal.

   2. Execute this command:

      defaults write com.apple.desktopservicesDSDontWriteNetworkStores true

   3. Either restart the computer or log out and back in to the user account.

If you want to prevent .DS_Store file creation for other users on the same computer, log in to each user account and perform the steps above—or distribute a copy of the newly modified com.apple.desktopservices.plist file to the ~/Library/Preferences folder ofother user accounts."

My Mac returns this:

2010-08-02 20:15:35.567 defaults[15865:10b] 

Rep argument is not a dictionary

Defaults have not been changed.

??? 

dot_clean is only present on MAC OSX 10.5 up to the latest. 10.4 does not have it.

hello, 

sorry for ignorance/incompetence, but can someone tell me exactly how i’m to use kopymac to copy files from the Mac to the Sandisk? I’m stumped. 

When I went to one of the KopyMac download websites earlier, there were cursory instructions there. 

I just found these, which may help–hope so.  (And actually, there is a lot of other good info. at the linked site, in the main article as well as the comments.)

http://guyscharf.wordpress.com/mp3-on-macintosh/

thanks, will look into it, though i’ve also managed to FAT corrupt the disc, so i can’t use it at all now. d’oh!

Time to reformat …   :wink: