Mp3 files are creating ghost file

When I drag mp3 files to Clip from my Macbook from Itunes it loads the music.  When I disconnect the Clip to use it I have 2 of every song and one file doesn’t play.  The Clip constantly skips over these files. I cannot stop on one to delete it.  The files look like ._01"Title" ._02 ._03 etc.  How do I clear this thing back to factory and why the double files??

GaryMalibu wrote:
When I drag mp3 files to Clip from my Macbook from Itunes it loads the music.  When I disconnect the Clip to use it I have 2 of every song and one file doesn’t play.  The Clip constantly skips over these files. I cannot stop on one to delete it.  The files look like ._01"Title" ._02 ._03 etc.  How do I clear this thing back to factory and why the double files??

New to the Mac world Gary? I had the same question when I first switched to Mac. Those files are used by Finder to navigate, and are a massive PITA! I have found it easiest when I add files to my players from my Mac to connect to a PC when I have access to one and then Delete them. Also you can delete them 1 by 1 using the internal delete function but that takes a while. I have yet to find a really good solution for this that doesnt involve an additional step after you disconnect from the Mac. Also may help to check this out… Mp3 on Macintosh

I have the same problem. I use my Clip+ for podcasts only. I get 2 of everything and was blaming it on stupidity on the part of Sansa. My Bad! In my case, all of the podcasts play, there are just 2 folders. One is identified as Untitled. Thanks for the tip CB!

Thats the problem.  When I connect it to pc or even mac they don’t show up.  They only show on the player and I cannot delete them unless I delete all the good music files first.  The player just scans by the bad files and goes to a good one so I cannot delete them. 

GaryMalibu wrote:
Thats the problem.  When I connect it to pc or even mac they don’t show up.  They only show on the player and I cannot delete them unless I delete all the good music files first.  The player just scans by the bad files and goes to a good one so I cannot delete them. 

 

On the PC you may need to change your settings to show hidden files. Or if the files are in a folder on the player you may have to look in those folders. On the mac They wont show up at all. 

I already run Ubuntu on my Mac using VirtualBox. As an experiment, I put my Podcasts folder from iTunes onto my Sansa USB Drive. Then I transferred the folder to Ubuntu. To make a long story short, it worked. I got my seven podcasts without any duplicates. For those who are 100% Mac, this is a free alternative. Kind of a pain, but as far as I can tell, it works. I don’t expect Apple to ever go out of their way to support anything but the iPod in iTunes, Windows or Mac. So we gotta figure stuff out on our own.

EDIT/UPDATE:

I used the same above method to put all of my iTunes songs on my Clip+. Had to convert everything to OGG, since the Clip+ does not recognize AAC HE files, but that is for another post. Everything works just fine.

Message Edited by wplj42 on 11-24-2009 11:30 AM

@conversionbox wrote:


@garymalibu wrote:
When I drag mp3 files to Clip from my Macbook from Itunes it loads the music.  When I disconnect the Clip to use it I have 2 of every song and one file doesn’t play.  The Clip constantly skips over these files. I cannot stop on one to delete it.  The files look like ._01"Title" ._02 ._03 etc.  How do I clear this thing back to factory and why the double files??


New to the Mac world Gary? I had the same question when I first switched to Mac. Those files are used by Finder to navigate, and are a massive PITA! I have found it easiest when I add files to my players from my Mac to connect to a PC when I have access to one and then Delete them. Also you can delete them 1 by 1 using the internal delete function but that takes a while. I have yet to find a really good solution for this that doesnt involve an additional step after you disconnect from the Mac. Also may help to check this out… Mp3 on Macintosh

 

The same thing happened to me, but when I tried to delete them from the player, it froze and now it’s not working… and the computer’s not recognizing the player

Message Edited by LostParadox on 11-24-2009 11:03 AM

Message Edited by LostParadox on 11-24-2009 11:03 AM

I am still not getting anywhere and the Best Buy people are confused as well.  I can’t get the ghost files to appear in the music folder in Mac or Vista.  

I just had a good online chat session that has solved this issue for Mac  users.

 The ._ track names are a result of the way Mac OS handles files. the simple solution is to mount your Sansa player in MSC USB mode.

Next open the terminal window and type “dot_clean” followed by a single space. then drag the “Music” directory from the sandisk player into the terminal window (this copies that path to the mp3 player into the terminal window), then hit the return key. Unmount your player and you should be good to go.

This simple command cleans the player of the obnoxious ._ files.

cnymike wrote:

I just had a good online chat session that has solved this issue for Mac  users.

 

 The ._ track names are a result of the way Mac OS handles files. the simple solution is to mount your Sansa player in MSC USB mode.

Next open the terminal window and type “dot_clean” followed by a single space. then drag the “Music” directory from the sandisk player into the terminal window (this copies that path to the mp3 player into the terminal window), then hit the return key. Unmount your player and you should be good to go.

 

This simple command cleans the player of the obnoxious ._ files.

 

 

Might as well jump in on this thread. Everyone else has.

http://forums.sandisk.com/sansa/board/message?board.id=clipplus&thread.id=6417&view=by_date_ascending&page=1

:stuck_out_tongue:

hello, i tried and this and nothing happened.

i have deleted all the music files i can see in the sandisk and it tells me i only have 1.37gb available.

kopymac didn’t help either.

any suggestions? 

oops, not used to this forum - i was supposed to quote the post that suggested using the dot_clean command in terminal

It could be that there are files that were transferred under USB MTP mode, which are invisible to your computer when connected under MSC mode (and also, vice-versa).

I’d try reformatting the Clip+ under its System settings to clean everything up; set USB mode to MSC; and then start fresh, using Kopymac or one of the other listed methods.

Keep us advised–

Thanks for your help.

I was already in MSC mode as I was advised that this was best for a Mac.

I tried it in MTP and my Mac didn’t even recognise the device.

I restored the factory settings and formatted the Sandisk and it now has 7.15GB free.

I think I’ll get another iPod when I have the cash.

Apple know how to make money! 

LeftTurnClyde wrote:

Apple know how to make money! 

 

That they certainly do. Produce a mediocre product that uses only proprietary formats and wayyy over-priced accessories, ‘leak’ so-called secrets ahead of the release to create a huge demand for it months before it’s available, spend the money they should have spent on the product itself on advertising and ‘hype’ instead, and give their products away to schools to ‘hook’ students to their brand name.

Hmmm, kinda sounds street-corner drug dealers . . . and we put them in jail.

but they’re so purty.

and PCs are too confusing.

not as confusing as trying to get this sandisk to work properly though i suppose.  

The Mac transfer issue has been mentioned in other threads.   

Easy to solve.  (1)  Keep your Clip+ in MSC mode for the Mac.  (2)  Use Kopymac (Internet freeware) to transfer files onto the Clip+, to prevent your Mac from adding extraneous files that will crud things up.

Voila–done.

Other solutions exist as well; see the other threads on the topic.

http://forums.sandisk.com/sansa/board/message?board.id=clipplus&thread.id=6417&view=by_date_ascending&page=1

http://forums.sandisk.com/sansa/board/message?board.id=clipplus&message.id=6315#M6315

Message Edited by Miikerman on 08-10-2010 03:52 PM

The Mac transfer issue has been mentioned in other threads as well.   Now that your Clip+ is back in pristine, new condition with your reformat of it:

Easy to solve.  (1)  Keep your Clip+ in MSC mode for the Mac.  (2)  Use Kopymac (Internet freeware) to transfer files onto the Clip+, to prevent your Mac from adding extraneous files that will crud things up.

Voila–done. 

Other solutions exist as well, to the Mac adding the extraneous files; see the other threads on the topic, and as discussd above.

http://forums.sandisk.com/sansa/board/message?board.id=clipplus&thread.id=6417&view=by_date_ascending&page=1

 

http://forums.sandisk.com/sansa/board/message?board.id=clipplus&message.id=6315#M6315

thank you!

Connect your MP3 player to your Mac, delete the unwanted songs/files and empty them from trash also. As simple as that! If you have your ’ Get Info’ of player open you will actually see the available space increase by that much.