Songs are missing after firmware update

Hello,

i updated my mothers Sansa Clip 8GB today via Autoupdater. Everything works fine, except that the root folder is different now and the music dissapeared somehow. Well, the music is still there (It is 4,2 GiB of 8 full), you can even hear it. It just dissapeared on windows (XP, Vista and 7). How can I “rescue” the music?

Greetings

If you reset your USB mode under Settings back to what it was set at before, the music should be visible again; when you update the firmware, the USB mode gets reset to Auto.

When your player is connected to your computer under USB MSC mode (set under the player’s Settings/USB Mode), your computer only sees the files that had been transferred to the player when the player was connected under MSC mode.  Likewise as to MTP mode.  Regardless, all the files show up and are playable on your player, under whatever USB mode setting.

A good reason why some people prefer to set the USB Mode on their player to either MSC or MTP:  on the Auto setting, the player tries to connect under MTP mode but then will fall back to MSC mode if the MTP connection does not work; the result being, you may have a mix of MSC and MTP mode transferred files on your player, making some of them not visible on your computer without switching to the other USB mode. 

Because MSC mode is more universal (playing with a broader range of operating systems, including Linux and on Macs, and without a need for Windows Media Player on the computer), some people prefer MSC mode.  However, note that DRM (digital rights management) files need MTP mode–they will not transfer sufficiently (the DRM license will not transfer) under MSC mode.  

Thank you, worked for me.  :smiley:

Please help, after updating version 2.01.32A to 2.01.35, all of my songs in the Sansa clip disappeared. I followed what had suggested here by changing the Mode to MSC and MTP and then “auto detect” but none of them work!

Try resetting it.

Thanks for your promptly response, Tapeworm. I did re-set it, but the songs are still missing. I Checked both ways, by the 8 GB Sansa Player and through the computer, they all shown " used 4.86 GB, free 2.74 GB, but still can not find where those song are.

Assuming that you have the music elsewhere (like on your computer), a simple solution would be to reformat the Clip under its Settings, which will clean everything up, and then transfer the music to your Clip again,

You are right, reformat , clean up the clip and restart everything over is the only solution. I did reformat and transfer the songs back to the clip, it worked fine. Thanks a million, Mikerman.

:smileyvery-happy:

Cool!  And glad you’re up and running (well, listening) again.   :slight_smile:

This really underscores the importance of keeping the original music/book files stored away somewhere on a computer or backup drive, and not storing the only copy on the Clip (or any portable player) itself. 

To All,

Solving the problem or not, All of your willing sharing and support when people ask for help, they are very helpfull in this forum, lady and gentlemen.

Thanks you all,

:smileyvery-happy: