Song not in alphabetical order

I’ve just bought a 2gb Sansa Clip, but I’ve noticed that the song (both browsing them by clicking “Play all” or “songs”) aren’t actually in alphabetical order, they are sorted by initial letter but then there are some “errors”.
For example:

-Around the world
-A Modern midnight conversation
-All right reversed

I’m connecting it to my PC ad “Msc” and I’ve copied the mp3 files directly in the “Music” folder, without any other subfolder.

Is it normal? It’s quite annoying.

That is in alpha-order.  Remember spaces are considered as characters and affect the name.

if I had 3 files “abc” “a bc” and “ab c”, they would display as alpha order :

ab c
a bc

hence your A+spaces come after your A+letters.

Ok, btw as far as I know the order would be:
a bc
ab c

By the way, why “all right reversed” is after, for example, “atwa”? That makes no sense, to me

sorry I was mistaken, that isn’t in alphbet order, I misread your first post. 

No problem at all :wink:

up :slight_smile:

up up!
It seems like the song are divided somehow in two groups, but I don’t know why.
Maybe id3 v1 and v2?

One thing I’ve noticed is that songs which have been copied to the Clip in MSC mode do not always show up in correct alphabetical position compared to songs copied in MTP mode. 

For example, I have a song called “Cymballine” (Pink Floyd for all you oldsters out there) that shows up before “Cat Scratch Fever” (yep, I’m an oldster).  The first was copied in MTP mode, the second in MSC mode.

I would like to play music alphabetically. I was able to initially, now I cannot.

Play All will play all your songs alphabetically by title–with the considerations of spaces (a bc) above. 

Within each album, there’s a workaround. 

Get mp3tag. It’s free.

When you install it,  you have an option to add to context menus–allow that.

Open and go to Tools/Options/Tags/Mpeg. Make the tag version ID3v2.3 ISO-8859-1. Those are preferred by Sansa. You can save that as a default.

Open one of your albums and highlight all the files.  Under Convert you can choose Convert Tag to Filename. Put %title% in the window and the files will be named as the titles. Then, under Music on the Clip, scroll all the way down to Folders and choose the album and it should play the songs in order by filename, which is now in alphabetical order.

This preserves the track numbers, in case you’d prefer to hear the album as the musician intended. 

@donatocabrera wrote:

I would like to play music alphabetically. I was able to initially, now I cannot.

As a general matter and apart from under the Folders option explained above, the player organzies files for playing uaing the “ID3 tags” for each file/song–the data provided for each song providing the song name, album, artist, year and genre, among other data.  If the ID3 tags for your songs are fillied in, and correctly, and then you choose Play All in the play options (as noted above), your songs will play alphabetically.  You can add/edit the ID3 tags using feeware such as MP3Tag, which tends to be recommended, or using the Windows Properties/Details tab for the files 1-by-1 (fine for 1 file but more cumbersome if you’re doing a bunch of files)