Solve my Win10 ReadyCache issue (early Win10 upgrade user)

Basically the steps listed here, with 2 important steps missing from the manual fix:

Before you start, do this:

  1. Use disk partition and delete the partition on the ReadyCache SSD.

  2. You need to go to your %tmp% (typically Users\Account\AppData\Local\Temp) directory and delete everything before you start, some files might be in-use and locked, but delete as much as you can.  Apparently there is a chance that some old file is interfering with the installation.  (I ran into ExpressCache App launch issue and license retrival error)

Manul fix here:

*If you already removed your Windows.old path, SanDisk people can send you a copy of it.  I do have a copy of it but I don’t want to get into any legal issue by sharing it.

This has resolve the issue for me.


I have faced the same (Windows 7 upgraded to Windows 10 adopter) issue and I have been patiently waiting for the fix just like the others on this forum. I must have tried the manual fix a few times but it doesn’t work. It gives me the dreaded message about the missing msihelper.dll file. I cannot uninstall the program from the control panel due to the same missing dll error.

If there is a custom installer file to fix this error I would love to have it.


From what I gather, basically the Win10 upgrade path leave ReadyCache in a bad state.  These are the high level step to resolve it:

  1. Unintall the current bad installation (Windows.old copy method).

  2. This allows you to install ReadyCache again, and you need to stop the ReadyCache service

  3. Then you do another uninstall, this should clean up all bad state.

  4. Then you install again, this time it should work normally.

It looks to me that you are stuck on step 1.  If you still have the Windows.old files you can copy it and give it a try.  Otherwise uninstaller tools should help in this case.

What I personally had encountered is some bad files in my %tmp% path which prevents a good installation on step 4, once I sort that out it’s been working as before for me.

I tried revou uninstaller. It doesnt even detect ExpressCache as a software that is installed on the desktop but ExpressCache shows up in the “Programs and Features” list. I am at a loss right now :frowning:

Do you still have a copy of the software under Windows.old folder?  If not, you can ask ‘georgealon’ for it.

Yes, I have the files from the Windows.old folder. I followed the instructions and restored the folder to C:\Program Files.

I confirmed that the MSIHelper.dll file exists under the C:\Program Files\Condusiv Technologies\ExpressCache folder but when I try to uninstall ExpressCache I get the MSIHelper.dll not found error.

I kind of recall that happening to my PC but I don’t exactly remember what I’ve done to resolve it.

Try this maybe:

Also check the device string in the registry, not sure related but just to eliminate causes:


I was finally able to uninstall ExpressCache using “Uninstall Tool”. I rebooted the computer after the install and tried to run ExpressCacheSetup.exe again but this time I experience a new error:

Failed Installing ExpressCache SanDisk Drivers. Error:1612