ExpressCache is no longer working after updating to Windows 10 Manual Fix

When Windows 10 was originally released core components of ExpressCache would be removed during the Windows 10 upgrade process. Microsoft has now patched the Windows 10 upgrade process to prevent this from occurring however any ExpressCache user that upgraded prior to this patch will notice that ExpressCache no longer works after the upgrade. We are working on a tool that will repair the ExpressCache software and allow it to run normally and we expect to release this tool by the end of the month. 

In the mean time if you are experiencing this issue and would like to get ExpressCache running I have posted below the steps to manually fix the ExpressCache installaiton. 

All steps below are required including all reboots. 

During the upgrade to Windows 10, Windows moved all the files in C:\Windows\Program Files\Condusiv Technologies to 

C:\Windows.old\Program Files\Condusiv Technologies:, This not only caused the ExpressCache software to not function, it also prevented uninstalling of the ExpressCache software. 

 To resolve this First we need to uninstall ExpressCache

  1. Copy all files located in  C:\Windows.old\Program Files\Condusiv Technologies to  C:\Windows\Program Files\Condusiv Technologies
  2. Uninstall ExpressCache
  3. Reboot
  4. install ExpressCache  - no reboot required
  5. In the search bar search Services
  6. Right click the ExpressCache Service and Select Properties
  7. On the properties Screen change the Startup Type from Automatic to Manual
    services.jpg
  8. Reboot
  9. Uninstall ExpressCache
  10. Reboot
  11. Download and install ExpressCache again
  12. Reboot.

Once this has been done ExpressCache should work normally. 

Forum Admin

slotmonsta

I was unable to unistall all instances of express cache from my system. Still can’t find msihelper.dll

I was able to uninstall but can not installe, cant find my SanDisk cache …im getting WERY TIRED …

did the uninstall / install multiple time, still couldn’t get it to work for Win 10:

Issues:

  1. eccmd -info -> Failed to retrieve product license information.

  2. ExpressCache app -> ExpressCache can not launch. Try using the original user account for the first time.

Checked registry for existence of: SCSI\Disk&Ven_SanDisk&Prod_SDSSDRC032G…

This manual method worked for me.

There was one difference – at step 11, download and reinstall ExpressCache again, when I first booted a window popped up that said something like “Express Cache did not uninstall completely”.   And when I ran the setup progam to re-install it, the program instead asked me if I wanted to UN-install it – so I said yes, let that uninstal finish, rebooted again, and ran the setup program again – and this time it offered to install the program, which I did.

I also installed the app – for the first couple boots I was worried, as the cache seemed stuck at 0.07GB, but a couple more boots and it started filling up at a good clip with a good percentage of reads coming from the cache.

Thanks Slotmonter and Conducive programmers!

Can someone post a zip somewheres of thier “C:\Windows.old\Program Files\Condusiv Technologies”? I deleted my Windows.old before I noticed this issue (I know right? I even work in IT…shame).

Thanks in adv!

I have a problem with my Ready Cache SSD. I can not play Gefixte Software Express Cache for Windows 10th Because in Device Manager is to SSD under Ergebisse: The unit “SCSI \ Disk & Ven_SanDis_ & Prod_SDSSDRC032G \ 4 & 118795f3 & 0 & 000000” could not be migrated. Thus, the software does not find namely the SSD. My question is how I can in the Regedit for the device “SCSI \ Disk & Ven_SanDis_ & Prod_SDSSDRC032G \ 4 & 118795f3 & 0 & 000000” shall be migrated? After update until now I have the Sandisk Ready cache used with Intel® Smart Response Technology, as the Software Express Cache until recently not 10 running under Windows. Now there is a fix for the software. Only the Software Express Cache can not be installed because the can not find the SSD and I think that at Intel SSD Cache Intel® Smart Response Technology use in the Regedit what has bent flat. Therefore, the device can “SCSI \ Disk & Ven_SanDis_ & Prod_SDSSDRC032G \ 4 & 118795f3 & 0 & 000000” could not be migrated. The Intel® Smart Response Technology, I have planned only as a temporary stopgap. But the software Express Cache caches all HDs in system no matter which controller hanging. While the Intel® Smart Response Technology, only the boat caches Raid 0 drive. I have two HD’s as Raid 0, a HD 3 TB as a data HD and HD for backups. Thus, the Software Express Cache is much better in the function in connection with my Sandisk SSD Cache Ready. I want to save my Sytem themself. So I want that fixed on the Regedit. I just do not know where I put there because He has value SCSI \ Disk & Ven_SanDis_ & Prod_SDSSDRC032G \ 4 & 118795f3 & 0 & 000000 the SSD is migrated.

I had the same issue. There is a mistake in step 1.

The post incorrectly says:

  1. Copy all files located in  C:\Windows.old\Program Files\Condusiv Technologies to  C:\Windows\Program Files\Condusiv Technologies

  2. It should actually say (don’t copy to C:\Windows\Program Files but instead copy to C:\Program Files):

Copy all files located in  C:\Windows.old\Program Files\Condusiv Technologies to  C:\Program Files\Condusiv Technologies

Edited to add… this appears to have worked for me.

But I have uninstalled Software Express Cache still under Win 8.1. So before I did the update to Win 10th Because I had read here that there are problems under Win 10. Thus I have no file can I move. Also I immediately deleted immediately after Windows.old for update.

I guess the Intel SSD where I as Intel® Smart Response Technology was causing the problem in the Regedit because after disabling the Intel® Smart Response Technology feature is the problem the unit "SCSI \ Disk & Ven_SanDis_ & Prod_SDSSDRC032G \ 4 & 118795f3 & 0 & 000000 "Could not be migrated.
Sodas the Software Express cache does not find. My question is how do I fix the problem?

LordWotan,

Apparently you are not the only one with the same issue. Please try to change the string in your registry key:

Ven_SanDis_&Prod_SDSSDRC032G to

Ven_SanDisk&Prod_SDSSDRC032G

Somehow SanDisk became SanDis_, Not sure why…

After that you should be able to install the software.

Any chance you can post your “PF\Condusiv Technologies” in a zip file somewhere (OneDrive/Google Drive, etc) and share it w/ me? I would really appriciate it.

I removed Windows.old too…

any solution? :mansad:

@georgealon

And how and where do I change the Regedit.

LordWotan,

  1. Open the registry: right click on the Windows program button (lower left), select “run”, type “regedit”, click OK.

   This should open the registry.

  1. Browse to the key:

 HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\disk\Enum

1.  Open the registry:
     Right click the Lower left Windows button and select “run”, type “regedit” and click OK

2.  Browse to the key:

     HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\disk\Enum

  1. Change the registry value that shows Ven_SanDis_& to Ven_SanDisk&

  2. Try to install ExpressCache

http://i.hizliresim.com/ZVoQzZ.png

samsung np550 pc 1 tb+8gbssd hybrid disk.

cmd

diskpart

select disk 1

clean

its ok.

uninstall the express cahce ok

but i can’t install expresscache please help how to handle it manualy.

Necipt,

You need a ReadyCache device to install ExpressCache software.

It will show SDSSDRC032G in the registry.

when i use windows 8 , it was working?

8 gb ssd not working now

It’s a 32GB SSD, not 8GB

ok. you say expresscache is only for 32gb ssd device.

what is mine ?why the 8gb ssd not working ? do you have any idea or can you help me?

http://i.hizliresim.com/aDr2nd.png