ExpressCache does not accept Sandisk SSD U100

Probably the title says it all, but here’s the long story ( short summary below ): I have an Asus S400CA which was shipped with the Sandisk SSD U100 as SSD Disk cache. The last weeks everything seemed to be very slow, even under Windows 8.1.

Then I upgraded to Windows 10 (mid-September) and still everything was extremely slow. The HDD was always busy by ExpressCache Service, so I looked at the Version (1.0.86 as far as I remembered). From the Sandisk Homepage I downloaded Version and tried to install it. The installation progress goes to about 6% and then gives an error message: " Could not find a SanDisk ExpressCache device on your system." Looking into the device manager there was the SSD working fine.

Next step: going to Asus support homepage Found a zip file to uninstall the old and install the new driver, officially for those who updated Windows before 25th August 2015. Uninstall program “ECWin10Cleanup.exe” was successful, but installing the new driver failed again (Could not find a SanDisk …).

In another thread of this forum I got the hint to look up in the registry, if SanDisk was written correctly, because sometimes it changes to SanDis_ and the missing k stops the installer. Well, as you can guess, that was not the problem.

I now tried different things like opening ExpressCache Setup as administrator, … nothing helped.

Now to the funny part of the game: I read somewhere that ExpressCache looks in  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\disk\Enum for the phrase “SDSSDRC”, so I changed the “SSD U100” to that and suddenly the installer worked to 100%. But then it does not say “finish”, but it waits for about 32 minutes and gives me an error then. For me it seems that there is a programming error in ExpressCache, but others say it works. Any suggestions.

Summary :

  • ExpressCache Setup does not accept my originally shipped Sandisk SSD U100, giving me the error message  " Could not find a SanDisk ExpressCache device on your system." after about 6% progress.
  • Old Version of ExpressCache was uninstalled successfully by a special program " ECWin10Cleanup.exe" provided by Asus.
  • Entry in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\disk\Enum is correct (no change from SanDisk to SanDis_)
  • Changing “SSD U100” in that registry entry to “SDSSDRC” starts the installation process going up to 100% progress in the display, but sill finally failing.

Can somepne help me with this?

The retail version of expresscache on the sandisk site does not work with the U100 ssd. you will ahve to use the version linked on ASUS’s website. If you are having issues with the ASUS version of the software you should contact ASUS for support.