ExpressCache is no longer working after updating to Windows 10 Manual Fix

I upgraded my W7 to W10 on my ASUS UX32A ultrabook.

Then I cloned it (500GB HDD) to an SSD (500GB).

When I looked for the Sandisk 24GB SSD to use it as a drive it was nowhere to be seen.

How do I restore the Sandisk 24GB SSD for use as a drive?

Use the disk partition tool to create and format the drive for normal usage.

This  is rather frustrating.

Windows.old has now gone.

Tried uninstalling once so now there’s nothing to uninstall!

Tried re-installing (using ExpressCacheSetup,exe) but this fails to an error message “Please uninstall and re-run setup”

Now nothing to uninstall.

Then set-up says " System has not rebooted after uninstalling expressCache.  reboot the system and start ExpressCache installation"

I’m going round in circles here.

Can anyone help before I throw the thing away!

someone had posted a link for the file.  I think there’s also a workaround to edit the registry to enable the uninstall.

JJKK, when did you perform your win 10 upgrade? was it couple a months ago or just recently?

@georgealon Thank you, now it is running

I’m having a similar problem - my Windows.old folder is gone, and I don’t see the registry key with value “Ven_SanDis_&” under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\disk\Enum

I only see “DiskSanDisk_SDSSDRC032G”

Express cache does not work with Intel RST v. When will the fixed?

It’s now been several more months, apparently this is still a problem.

I have an HP machine with a 16GB sandisk ssd drive,  since upgrading from 8.1 to 10 (today) I’m unable to use the drive as a cache drive, I’ve uninstalled expresscache and reinstalled several times (the lenvo 64bit one, 1.3.118 and earlier versions.) wiped the cache drive, removed the MBR, etc  Then tried the one linked early in this forum (1.3.2)  the one on this forum reports:

“Could not find a Sandisk expresscache  device on your system please plug in your sandisk express cachedevice.”   

I’ve checked the drive in the bios hardware test, and in the registry it’s reports it accurately:   “SCSI\Disk&Ven_SanDisk&Prod_SDSA6GM-016G-100\4&2f202cce&0&010000”  so it does exist…     Even in disk management it’s shown as a healthy 14.91GB primary partition (not formatted / not available in explorer.)

So,  how can I convince expresscache that the SDSA6GM 16G drive is in fact what it is (sandisk ssd)


Was able to fix it:  first I grabbed the EC.LMF HP file that someone was kind enough to host (google it),  then I removed express cachce with  “ECWin10Cleanup” from asus,   THEN I installed the 64 bit lenovo expresscache (1.3.118), finally, before rebooting I renamed the ec.lmf file there ec.lmf.bad and copied the hp EC.lmf file into the directory.    

Upon reboot I now have a functioning SSD cache (a few hours later, 5 gigs of the cache is used :slight_smile:

WOOT says I.  Woot.

I haven’t yet upgrade to Win10 on my laptops with ReadyCache from Sandisk.  Is it now safe to upgrade?


ExpressCache was not designed to work for Windows 10 natively. Updating to Windows 10 sometime may cause issue with ReadyCache installation. In the event of encountering any issue using ExpressCache software in Win 10, you can request SanDisk support for a CleanUp tool that should clean Uninstall it. Re-installaing should get things going for you.

I hope that answers your query.



a few questions re below fix;

  1. My expresscache files are in folder ‘diskeeper’ instead of ‘Çondusiv Technologies’

  2. How do I install ExpressCache software after uninstalling it? I do not have a disk, laptop came with software pre=installed

Thanks in advance!

in addition to my previous post; I have an 8 GB SSD. Does that matter for the new software?