Slow output..OMG

hi, just got my Clip+ today. after dragging music to the base memory, i kinda shock as the output is really really slow. what happen? i increase the volume level to maximum yet i get really upset. can someone please help me on this


You’re going to have to give us more to go on. What kind of files are they? Is the output (playback?) slow or soft? Stuff like that.

Too much info is better than not enough. :wink:

If the volume is too soft/low:

Under the player’s System Settings under Settings, choose Reset, and then choose N America or Rest of World for your region.  You then should have a High volume option under Settings/System Settings/Volume, which you should select.

Which headphone are you using? Some headphones are much more efficient than others. A more efficient headphone or earphone  might give you much more volume

is it? i will try it and will let you know about it. i did email the Sandisk techical team, same question ask, and they replied me this:-

'Thanks for emailing SanDisk Technical Support. It is our goal to make sure you have all the resources you need to get the most from your product.

There is an EU regulation that states that the player should have a maximum default volume of 85 decibels.
Cause of that the Volume setting had to be disabled as with the High option selected the volume would go above the recommended maximum volume.
Unfortunately we can not recommend you to do something to reverse this as we would go against an EU regulation.
Other customers are not bound by the same legal restraints that we are to provide a solution so they may have posted some helpful information.
So it would be recommended to try to find a solution on the Sansa forum.’

So, I guess i should reset it and choose other region but not the Europe region. am i rite?

im using the stock headphone. havent plan on getting a new headphone. do you have one in mind? 

I looking at the track info it is ‘CODEC (mp3) Metallica - Enter Sandman’… so, as you can see, this is metal band, not a soft song. i put the volume to maximum yet the output not very satisfying.

go to the setting menu and reset all or reinstall the latest fimrware. once done when it asks for your region select rest of world instead of europe. this will give you a high volume option in the settings menu and will increase the volume level. EU regulations are a hassle in my opinion but companies have to follow them. 

firmware? yes, i did install the latest one( i think), its the 01.02.15F version. the player currently with my friend, will try to reset it and change it to other region. oh, one thing, will it wiped all my music in the player base memory?

no the files will not be wiped out. no worries