(Second) Windows 7 not letting me load cruzer

Hi all. I know that this subject started on a different thread, but my problem seems to be moving in a different direction - hence the new thread! If this is not appropriate, just let me know and I’ll move my question.

I recently purchased a number of CruZer’s (2x4gb, 8gb, 64gb). All work fine on an XP desktop, one of the 4’s gb and the 8gb work fine on my (Dell Windows 7) laptop. However, the other 4gb and 64gb don’t work.

Most of the time, when those not working are plugged in, there is no recognition (or reaction) from the laptop. Sometimes, the laptop seems to try to recognise the CruZers (the green bar in the Explorer application progresses from left to right) but never finishes! (The drive reference remains visible, but if you try to do anything - format / create folder / paste files / etc. - the operation fails as the drive is no longer present, even though it is still plugged in.)

I would have thought that the problem is with the CruZer cards, except that they work on another machine, and I would have thought that the problem is with the laptop, except that some of the CruZers work on the laptop!

Any / all suggestions, greatly appreciated.



Any / all suggestions, greatly appreciated.”

Oxidized USB port contact.  Low power.  Heat.  Too many USB devices plugged in.  Things unique to the machine rather than the Cruzer IMO.

Keep us posted to what you find. 

Thanks Ed. I thought / hoped that it wouldn’t be (laptop) hardware related. Assuming it is an oxidization / low power issue, would some devicies still work (some CruZers and all other USB devices - there are no other USB sticks / devices plugged in)?

I’ll have to return the laptop to Dell to fix, so it will take me sometime to comeback with an update.



With a Dell NB that I had years ago, when I had problems with a USB stick, probably 256MB, Dell came to the house and replaced the mainboard.

Which BTW did not repair the problem.  I eventually found that the USB stick needed to be formated with the LBA option set.  And that stick worked fine in another pc.  hmmm beginning to see a relationship here with your situation. 

Are these USB devices brand new?  Been formated?

The CruZers are brand new (working and not working ones). What does LBA stand for? I’ll try that tomorrow before I contact Dell (and because I got the laptop in a country other than my current one, I expect to complicate matters further).



What does LBA stand for?”

Logical Block Address.  http://en.wikipedia.org/wiki/Logical_block_addressing 

It’s part of an old format standard that some BIOSs apparently still check.

Thanks Ed.

In the meantime, on another thread in the Forum, someone mentioned a clash with (Samsung) KEIS. I disabled the various element of that program in MSCONFIG, rebooted, and all the CruZers work fine now.




I too have purchased several 64GB Cruzer Glide USB Flash Drives and having issues with my PCs recognizing them.  When I first inserted the FD in my Windows XP, everything went well.   I then went home to my Windows 7 and received a pop up that indicates the drive must be formatted.  Well, after getting good and aggravated, I did reformat the FD.   Now, I can use the FD on my Windows 7 but, cannot use on my Windows XP ---- plus, Windows XP will not let me format the disc. 

Anyone other than me having these issues and, if so, have you a resolution?


With Keis disabled and the Cruzer working can you manually change the drive letter assigned to the Cruzer then start Keis?  Do they both then work?  And do they work after you reboot?

I’m curious if the basic problem is Windows assigning the same drive letter to two different devices.

Ed, I went through the steps (re-assigned drive letter, then started Keis, then checked Cruzer) and it worked. However, without rebooting, and with Keis still running, I then ejected and re-inserted the Cruzer (as expected, it still held the new drive letter) - the Cruzer no longer worked. I then rebooted the laptop and inserted the Cruzer (before starting Keis) and it worked. I then ejected the Cruzer, started Keis, and re-inserted the Cruzer, but (as expected) it did not work. I don’t think that this is a simple drive letter issue (it is also worth remembering that 50% of my Cruzers did work with the initial setup (i.e. while Keis was running from startup)).

I’ll keep an eye on this thread and if there is anything else that you would like me to try, just let me know.



Thank you for the followup @lino.

I was having the same problem as @lino. Removing Samsung Kies cleared up my problem. I don’t consider Kies essential, so I’ll just leave it off my system. I just registered to post this and confirm that this problem exists for the benefit of anyone else encountering it.

I wanted to let Sandisk Guru know that Samsung Kies was causing a similar problem for me!  As soon as I rebooted with Kies disabled in Msconfig, then Ultra drive ok!

I would be interested in following up a resolution to this with Sandisk if you would be kind enough to work with me!


This tread in this forum really saved my day!

My USB-stick from SanDisk suddenly stopped working on this computer running win7, my other computer on win7 have no problem with the same USB-stick.

So I disabled Samsung Kies from the startup and now everything is back to normal :laughing:

Sandisk 1 - Samsung 0