Cruzer 8gb doesn't work!!

Bought a cruzer 8gb flash drive and it will not work on my computer or any of the other computers i have tried it on.

I’m very disappointed and will be returning it asap, however thought that I would post on here to see if anyone has any solutions.

I took the usb flash drive out of its sealed packaging, plugged it into my laptop that is running Windows Vista home premium, a little box came up at the bottom to say that it was plugged in and was working, didn’t bring up any boxes so went on to my computer toclicked on it from there. Said that I had to format, tried to format however stopped part way through and said that windows was unable to format. Can’t use the flash drive at all, has anyone cot any suggestions as to why its doing this, I have other makes of flash drives and have never had any problem, won’t be buying another SanDisk one if this is the quality.

Responses and suggestions welcome


Sounds like a bad drive. I’d return it and get another one.

Thank you, I have now returned it and after reading about the problems with sandisk products I have bought a verbatim store n go 8gb.

Hi monkeylover, you might need to uninstall the U3 software if it comes along with the USB you purchased.