SD Ultra 32GB SDHC 1 not accessible anymore


Last week my SD Ultra 32gb simply failed while taking pictures with Panasonic DSLR GX80.

Worked fine, took about 300 pictures that week, then all of a sudden the

Camera itself says no memory card installed just after switching the camera on.

SD Slot in Macbook Pro cannot read anything, it basically says slot empty, no reaction at all.

External USB cardreader does not work either.

MS Surface Pro 4 WIN10 no success.

I tried TestDisk & PhotoRec on both MAC and WIN, SD Card in various slots 

cannot be found.

Bought 3rd Jan 2018.

Card is not locked (write protection).

Any idea how to recover fotos on the card? 

Thank you so much for your help.



I have the same problem and hoped to have a solution or support here, on SanDisk offical forum.

Pity to see the company isn’t intersted in giving a minimal support.

FYI, this is a user’s forum, NOT a tech support forum. If you don’t receive any responses it means your question/issue is beyond the knowledge of anyone here looking at it & no one has a solution for you.

I would suggest directing your questions or problems to the tech support people at SanDisk. They are in more of a postion to help you.