ScanDisk daul drive 3.0

Good afternoon i please need assistance. I am using a 64gig scandisk dual drive 3.0.

I was always using it on our photocopier machine , perfectly without any problems. Last week i needed to format it and now all of the sudden the photocopier do not want to pick my usb up. Working perfectly on pc , tablet and also my iphone. Tried it on two photocopiers but no luck, sharp and minolta. Was working perfectly on minolta until i formatted the usb. Please please can anybody help me out, what might be te problem??? Thank you in advance

Why did you need to reformat the drive, rather than deleting the files and folders on it?
What format was the drive before you formated it? exFAT?
What format did you reformat it to? NTFS?
What app did you use to reformat the drive?
What drive formats do the photocopier machine’s instruction manuals say they can read?

In needed to format it for work purposes. There was nothing wrong with it before formatiing it. The format of the usb filing system was exFat and i reformat it again to exFAT. I made use of Windows 10 command promt and afterwards the normal format in my computer.

My orher usbs in NFTS format working on machine still, i even did a format of the drive in question to NFTS, but still no success.

Are there any kind of driver or something that needs to be installed on usb maybe, hidden file or so?

I don’t understand the difference between “command prompt” and “normal format in my computer”.

Is your computer UEFI based or BIOS based? UEFI computers have FAT32 EFI partitions. How many partitions does Windows’ Disk Management show for the USB drive?

Obviously reformating the drive changed the drive’s cluster alignment which may be the problem.


In that work required you to format the drive you should tell them they need to buy you a new drive. :slightly_smiling_face:

BTW NTFS is a poor choice for USB drives. It has more writes to the drive and wears it out faster.