Sansa Updater Install does not work at all.

First off, let me begin with the fact that I’ve troubleshooted this problem for 4 days straight now. I’ve un-installed, re-installed, system restored, safe moded,tried to find another way of getting SMC and the firmware, everything. I can’t find SMC anywhere online that’s the latest version, I can’t find another alternative means of getting the firmware, and I can’t find any way of getting this file to work.

So I’ll explain briefly whats happening. I launch the SansaUpdaterInstall.exe and wait…to no avail. The only thing that happens with it is that it keeps making a folder with various files in my application data area pertaining to it, but does the actualy Sansa Update launch? No, it does not. The only thing it does show is a brief two seconds of work, then stops bothering to do a thing after. It’s frustrating because this worked 5 days ago, then out of nowhere it just stops working when I decide to re-download SMC (The updater didn’t give me the option to download it at the time for some reason even though I lost SMC to a clean-up from a 3rd party program, so I thought re-installing Sansa Updater would give me the option). Of course I wasn’t expecting THIS to happen at all.

So I beg of anyone who sees this message, explain to me the reasoning behind this bizarre behavior irradiating from the installer, or for the sake of mercy give me some kind of link to the firmware and SMC. If all else fails, I’m just going to re-format my entire hard drive for a sure-fire way of fixing this (Assuming that it even fixes it in the first place, HAH that would make my day).

EDIT: After scanning through some topics, I realize that some people link troubled victims to the SMC section, telling them to not download the updater in the first place. The problem is we kind of NEED the updater to download SMC now, it’s like all traces of direct links to the recent SMCs vanished under the scope. But please, don’t tell me to not download the updater and to download SMC seperately. Because well, that’s just not…possible if you think about it.

Message Edited by Xyrhoshi on 01-15-2010 12:55 AM

Usually when this happens, it’s your firewall (Windows or otherwise) that’s blocking the connection to download and install the Updater.

Sorry, don’t even have a firewall. Windows Firewall is disabled permanently, and I already tried installing without my anti-viruses active. Didn’t work as I hoped it would. Any other suggestions?

EDIT: Also, as stated the launcher doesn’t even run. I highly doubt it has to do with my internet connection considering I should atleast get some kind of pop-up box saying that I’m attempting to connect.

FINAL EDIT: Well since noone seemed to have any inquiry on my problems, I decided to just format my whole drive and install a fresh copy of Windows XP. Of course, the Sansa Updater now finally works, but I really wish I could’ve avoided formatting. Well thanks for your help Tapeworm and others who attempted to help by thinking it over perhaps, but I guess it was useless bringing such a problem to this forum.

Message Edited by Xyrhoshi on 01-18-2010 03:24 AM

I really hope I don’t have to end up formatting my machine. That will really annoy me. It also seems rather like killing the baby because the bathwater is cold and you can always make another one… Of course from reading other “fixes” for problems with the SMC and SFU I get the feeling this is what the only solution is going to be. I love the player… I just wish Sansa would hire some better programmers for their software.

I have the same problem. Started the updater, goes out for a few seconds, then a pop-up saying I don’t have internet connection. WTF, how am I posting this message now if I don’t have Internet access.

The device is nice but the program and documentations sucks. Sansa needs better software engineers…they should hire

from Apple.

javelin wrote: Sansa needs better software engineers…they should hire

from Apple.

What? And have to de-program and un-brainwash all those clones? :dizzy_face:

Probably worth the effort… :slight_smile:

I also trouble shot this problem so I could get the latest version of Media Converter (which is also a royal pain) and in the end the problem was a network proxy server. The network has a hot LAN that has no closed ports of any kind. When I installed  Sansa updater on a Window XP that was on the hot LAN, everything worked. All the machines on the firewalled side of the proxy had a problem, even though the software installed with no errors. The software would install, but when I ran it, I would see a DOS window just flash for a moment and then disappear, nothing else. At first I thought I just had to “run as administrator” but that did the same thing. An error code of some kind would have been helpful. :cry:So, I was finally able to get the latest firmware updates and version of SMC, only to be rewarded with errors in SMC. What a GEM!