Sansa Fuze with Rockbox formatted by mistake

My sansa fuze had the stock FW as well as Rockbox. My son booted to Rockbox and accidentally formatted it. Now I can boot only to stock Sansa firmware, but it can play only media from the external sd card. PC also does not detect it.

I want to reinstall Rockbox, but that’s not possible as PC is not detecting it. I tried MTP, MSC, AUTO, all failed.

Please help.

I would re-format it using the Format option in the Settings > System Setting menu. That might set things right again. Note, this will also erase all files (music, etc.) that you have stored in the internal memory

Thanks, I did that, but the problem persists. The player charges when connected to PC, and I tried in 4 machines, Win2000, WinXP, Win 7, all fail to detect it, and there’s no yellow “?” in device manager. I’m stumped!

Don’t know if this will help, but have you tried a different cable? As I recall, there is a 30-pin port on the bottom of the Fuze. If a particular one (or more) of these has bent or broken, it still could be charging correctly, but not making a data connection. The fact that it won’t connect to any of 4 machines with different OS’s and regardless of USB mode is suspicious and is probably worth trying a different cable.

First, a corrigendum is called for : I mentioned that my son formatted thru Rockbox menu, it was in fact thru the Sansa FW. Does this also delete Rockbox?

Coming to the cable, well, unfortunately, I don’t have another cable to test with and it sure looks OK to me at both cable and device ends (though of course that’s no guarantee that its OK). I tried connecting it to my Samsung Galaxy phone thru USB OTG, but it too doesn’t detect the player. As I mentioned, the player currently can access only the files in the microSD Card, because the files in internal memory are gone. So my question is can any utility or FW file be kept in the microSD that can resolve the USB problem or even reinstall the FW (stock and/or Rockbox)?

If you format you lose everything on the internal disk, but retain the sandisk firmware and the rockbox bootloader which are not stored on the disk. You can either do a firmware update to remove the rockbox bootloader, or copy a new .rockbox folder to the internal memory.

Here’s what happens when I try to boot Rockbox (without depressing Rewind button on scrollwheel, I switch the player ON) :

Screen displays :

Loading firmware
File Not Found
**Rockbox logo comes here**

Boot ver 2.0

Then, it displays :

Plug USB Cable

I plug in USB Cable, it then displays :

Bootloader USB Mode
File Not Found
Plug USB Cable

Does the above indicate that the bootloader is also corrupt. As stated earlier, I cannot access the internal memory, so I cannot “deposit” any file there. What are my options besides trying with another cable (which I do not have)?

No thats normal. You can’t boot because you don’t have rockbox installed anymore. You need to reboot into the sandisk firmware and either reinstall rockbox or uninstall the bootloader.

>You need to reboot into the sandisk firmware and either reinstall rockbox or uninstall the bootloader.

Can you explain in detail how to do both in my situation?


I don’t see how that helps, as my player doesn’t show up in my PC.

Thats a link to the instructions for doing what you just asked me. Are you saying you tried it and it didn’t work?

I’m not sure which to follow in my case, the automated or the manual install, but I can see that both the cases require my player to be viewable and assigned a drive letter by my PC, please correct me if I’m wrong

Try to force the connection as follows. 

Sansa Fuze

  1. Turn device OFF.
  2. Slide the Hold switch down to Lock (orange color showing).
  3. Press and hold the left button ( |<< ) while connecting the device to the PC.

Yes, I read about it somewhere on these forums, after which I tried it out, but no luck still…

I think my Fuze is as good as fused, and I will have to be contented playing media files from the external SD Card only, although that might take a toll on the battery.

Thanks for trying to help.

Go back a step. It may still just be a bad cord. 

The charging connection and data connection are separate pins. One may work and the other may not.  

If you’re in the USA, you could get a new generic cord from Amazon for under $5 and try it.

I forget where I got my replacement cord, but I have gotten stuff from SF Planet and they’re legit. (I’d watch out for the super cheap sellers shipping from China.)

Cellphone accessory places might also have the Fuze cord–which is exactly the same as the Sansa E200 series cord.

Of course, you can also just keep loading stuff into the external card too.  Just don’t get an iPod cable–they fry Sansas.