Sansa Fuze not wanting to write songs (or anything) Solved.

In the past month i’ve been having problems,  I cannot write songs on my fuze v2.  It would have room however it could not write anything.  I tried formating it using the fuze format feature in the settings tab.  Nope, got rid of all my songs however when i tried to add songs to the player it would freeze.  Like it would say transfering however it would not transfer.  (songs on a micro SD could still be listened to though so it wasnt complete garbage)

So today i went at it.  I plugged in the player, went to windows my computer screen, right clicked on the fuze and clicked format (quick format selected).  Tried it, no change.

Then i descelected the quick format option The process took maybe 10 mins… What do you know it works.  I did not need to reinstall a firmware or anything.  After formatting the player the little hard drive would be empty however once you unplug it the " updating library" msg you see is what seems to install the folders.

Worth a shot.

Exact settings in the format screen


Fat32 (deffault)

allocation unit size 64kb

Volume Lebel


format options (both off - unchecked)

(off) quick format

(off) create an ms-dos startup disk