Sansa Fuze not recognized by Windows 7 laptop

Hi there,

My 8GB Fuze was recognized by my windows 7 laptop the first day I got it, and now it comes up as an “unrecognizable device.”  When you look at the properties, I get a Code 43 error, which means the device has “reported problems.”

I’ve tried the following with no luck:

-Every USB port in my laptop (including my USB Hub)

  • MSC/MTP/Auto Modes

-Can’t update the firmware since Windows doesn’t recognize it 

-Removing/Adding the device manually in device manager

Anyone who’s got something else to try would be welcome.  Thanks!

For the moment, stay in MSC and directly connected–not the hub.

Take a look at Solution 6 on this SanDisk page.

Don’t know if it’s applicable to Windows 7, but…

http://kb.sandisk.com/app/answers/detail/a_id/42/session/L3NpZC8qc2g3eHFQag%3D%3D/sno/0

Hey Rectangle, thanks for the idea…

I have to admit, I seriously tried all of these crazy solutions for HOURS when I realized I bought a non-sandisk cable as a part of a pack from Amazon.

I found my Sansa brand cable and everything works as it should.

DON’T USE 3RD PARTY CABLES, THEY’RE JUNK!!!   

Actually, I have two non-OEM cables and they work fine. But obviously, it’s the luck of the draw. Glad you tried the other cable!