Sansa Fuze freezes on "Refreshing your media"

Hello Internet. 

I have a Fuze, 4GB, I recently tried to add some music to the device and it got stuck on “Refreshing your media” so I reset the device and deleted the new tracks, it still got stuck. I deleted all the music off of it, it still got stuck. I upgraded the firmware, it still gets stuck, so I’ve deleted all of my music, photos, videos, everything I ever put on there. It still freezes up. I re-ran the firmware upgrade with nothing on the player, it still freezes. What the hell is going on? What of kind of cheap Chinese piece of crap is this? I actually paid $70 for this thing? It’s not even a month old and it’s doing this? What am I supposed to do? Prior to this incident, I would have had nothing but good things to say about this device, but in light of this recent development, my opinion of the device and Sansa in general is plummeting. Any help or advice with regards to this matter would be greatly appreciated. 

One more detail, just for the hell of it I left it alone for a while to see if maybe it was just slow and would eventually work itself out, well the time on the clock in the lower left corner has frozen as well, it reads 11:22 am and it’s currently 11:32 am by my watch I’m not sure if this is an important detail or not but I thought I would include it.

If your player is in MSC mode, plug it into the computer and look for the MTABLE.sys file.  This is the file that holds the data list for your files.  Delete that and unplug the player from the computer.  The fuze will rebuild this file when it refreshes.  Some bad data maybe left on the current mtable.sys file, preventing the fuze from refreshing.

I’m assuming that when you deleted all your files, you formatted it through the computer?

It’s possible that the most recent tracks you added were either corrupt or had something in the tags that caused the fuze to seize up.


Linux saves the day again! Penguin Power! After some more investigating, I realized that the device was reporting only 2.6GB of free space for a 3.9GB Filesystem. After exploring the contents and finding nothing, I looked for hidden files and BOOM there it was. “.Trash-0001” taking up about 960MB. I entered the directory and it had the files I recently added that seemed to be making it freeze up. These had been trashed locally (on the device) instead of deleted. So I deleted the directory. An actual delete, not “Send to Trash” disconnected, and behold! No more freeze up! :smileyvery-happy: My Sansa Fuze is resurrected. 

Now I know some things. Tags are important. I will be slowly adding music back to the device to see if I can find the EXACT cause of the problem so I can avoid further headaches. 

Normally this is where I would say thanks to everyone for their advice and assistance, but since no one helped me and I figured it out my own, I shall eschew that formality.

Given that your question was unsolved for less than an hour, and that you were apparently trying solutions previously supplied elsewhere in the forum (including tag info), you’re welcome. What were you using to delete your material initially?

I have exactly the same symptoms as the author on my 4 GB Fuze.  The only way I can access it at all is to connect it to my computer.  I can browse the Fuze’s internal storage, but anytime I try to use the Fuze, it gets eternally stuck at the “Refreshing your media” screen.  Eventually, the display turns white, and still later, the battery runs out.

Here’s what I’ve tried:

  1. updating the firmware.  This did nothing.

  2. erasing all the music I had on it, thinking perhaps a defective audio file was confusing the index algorithm.  Also did nothing.

  3. erasing the entire contents of the internal filesystem.  Again, it did not change the outcome.

Unlike the author’s, my Fuze had no hidden trash file, nor was the internal storage saying it was smaller than it should be.

What is going on here?  Is my Fuze just plain broken?

UPDATE: I fixed mine too!

Well, like this thread’s author, I stumbled upon a solution very quickly.  With the Fuze attached to my computer, I formatted the internal storage.  Then I disconnected my Fuze.  What a relief: it began acting normally again.  All the settings were at factory defaults.  I had backed up my music beforehand, so it was no big deal to reset the clock and such.

I guess the internal memory somehow got corrupted, so the indexing algorithm became stuck.

I’ve been running into the occassional freeze on Refreshing.  usually I reboot once or twice, wait the required ten minutes or so, and it’s OK.  In my opinion, this is the achiles heel of the Fuze.  the long refresh and occasional freeze when refreshing.  frequently it will do the refresh routine after the Fuze is plugged into USB for only a power-up- with no data being added or removed.

I had the same problem which went away after I ran the Ubuntu update manager with my 8G Fuze plugged into the computer. The computer looked frozen, so I unplugged the Fuze and computer and Fuze came back to normal. Dumb luck, I guess.

Thank you SO much for figuring that out.  I had the exact same problems.  I have RockBox installed on mine too, and that still worked, but not with the new media I had tried putting on Sansa’s OS.  Just went in and deleted that lovely trash file and voi-la!  Now it’s done refreshing my media & I can load more stuff.  Oh, but my system time is now all screwy, but whatever.  I can always reset that.

Thanks again!

I am haveing trouble with my Sansa fuze Mp3 player, I can’t get it to be found on my computer and when I look for drivers for the usb or mp3 player there seem to not be any, I have been working on this problem for a while and the way that was posted to fix it will not work if my computer can find the device. so it anyone has a real answer please let me know.

Turn the wheel until you see Settings.

Find System Settings.

Go to USB Mode.

Try MSC, and if that doesn’t work, MTP. Those are two different ways for the computer to connect to the Fuze. Auto  chooses one or the other, not always correctly.

If your computer still can’t find the Fuze your cord may be broken. You can get a generic one on Amazon, or from a cellphone-accessories company, that should do the job.