Sansa Fuze FM 8GB popping sound with 128kbps CBR MP3 and 01.01.15F Firmware

Hello SansaFix,

I have an 8GB Sansa Fuze with 01.01.15F Firmware. I did not use the Sansa earphones, I use some better ones from AIWA and SHURE.
With some 128kbps CBR MP3 music files I get a low frequency popping sound at playback some seconds after the backlight goes off.
When I press the middle button to turn the backlight on, the popping sound disappears until the backlight goes off again.

The popping sound is like pop-pop-pop-pop… with approximately 131.5ms between the pop’s.
It looks like during the pop the Sansa held its headphone output at a constant level for a duration between 1.8ms and 3.8ms.
This constant level is far away from clipping and it seem it is random respectively it is the actual music level when the phenomenon occurs. (I got this values with the help of a LeCroy oscilloscope.)

When I play the music files on a PC with Software MP3-players (foobar2000 or media monkey) and the same earphones, there is no popping sound during playback.

I have downgraded the Sansa Firmware back to 01.01.11F and the popping sound disappears on the Sansa.
So it looks like there is a bug in the actual 01.01.15F Firmware.

I make a big effort to investigate this effect and have tried a lot of thinks with this kind of music files.
The popping sound also appears with a fresh Sansa self-formatted memory with only one file at the Sansa.
I tried 5 seconds and 15 seconds backlight turn off time.

I have a lot of 128kbps CBR MP3 files which show this effect. These MP3’s are compressed with different encoders.

The files have only ID3v2.3 ISO-8859-1 Tags, but with other Tags the behaviour is the same.

Today I have already send one MP3 music example file and some oscilloscope screen-shots with this description to support@sandisk.com.

(Remark: support@sansa.com is not working, I got an error message back.)

The message subject is: “Sansa Fuze FM 8GB Bug with 128kbps CBR MP3” 

I hope you will fix this bug in the next, hopefully coming soon, Firmware release because it is really annoying also at louder music passages.

I am German so please excuse my English.

Best regards,

Andreas

PS.
There is also an bug in the German translation for “Empty”.
Instead of the correct translation “Leer” the wrong translation is “Leeg”.

(I think this is the Dutch translation, not the German.)
It is used e.g. in Playlists (Wiedergabelisten), GoList (Wiedergabeliste) when the list is empty.

This is one precise bug description!

Try to email the support message again except to this email: support@sandisk.com

I used to have 128 CBR mp3’s and I did not have this problem (That was before I re-ripped all my music to ~150 VBR). Have you tried encoding one with the LAME encoder? That’s what I used and it worked fine.

Now I use ~150 VBR and I still don’t have this problem, so I think it may be a problem with the container you are using. Try converting one of the files with LAME and see if that fixes it.

Head over to this thread:

http://forums.sandisk.com/sansa/board/message?board.id=sansafuse&thread.id=2844&view=by_date_ascending&page=1

It seems a lot of people have been having this problem.  Judging from the posts and SansaFix’s responses the skipping/popping sound has nothing to do with the audio files or their bitrate/format.  The problem seems to be the firmware and should be fixed in the next release.

Hi Gabe,

as I wrote, I already have send it to support@sandisk.com.

This 128kbps CBR problem only occurs with the actual .15F Firmware, the .11.F was OK.

So if your tries with the 128 CBR mp3’s are before the .15F Firmware, I can imagine that you did not had problems.

I also tried the LAME 3.98 encoder, sometimes this files are also popping.

Thanks for your help,

Andreas 

Added to the list.  You can mitigate by enabling the custom equalizer.

Hello akleiner, could you send me .11 firmware, I got some problem with poping sound too, so I want to try old firmware while waiting for new one :slight_smile: Thanks in advance though

Ps: My problem occurs when I push volume pass 90% at normal volume or 80% at high volume setting. Enable custom EQ won’t help :frowning:
Message Edited by plumpcheek on 11-05-2008 08:30 AM

Here are Links to the older Sansa Fuze Firmware Version 1.01.11:

For AMERICAS - Click here to download

For EUROPE w/o FM - Click here to download

For EUROPE w/ FM - Click here to download

For PACIFIC Region - Click here to download

Please use the instructions from SanDisk for updating your device on the official site:

http://forums.sandisk.com/sansa/board/message?board.id=sansafuse&thread.id=4880

I think downdating is on your own risk!


Windows Users can Connect the device in any “Mode” and follow the instructions below.

Mac and Linux users can connect their Fuze in MSC mode and follow the instructions below.

MSC mode instructions :

  • Turn on the Fuze
  • Navigate to “System Settings” on the menu of the device itself
  • Next, navigate to “USB Mode” and select “MSC”

  • Ensure your battery is > 50% full.
  • Extract the .zip file into a folder on your computer.
  • Once extracted, drag the file to the root directory of your Sansa Fuze.
  • Disconnect the Sansa Fuze and let it begin the firmware update.
  • Once it finally finishes doing its update, it will turn itself off. Turn it back on and once its back to the main menu, head to “System Settings” > “System Info”, and verify the “Version” is now 01.01.11"x".

"Ps: My problem occurs when I push volume pass 90% at normal volume or 80% at high volume setting. Enable custom EQ won’t help "

It sounds like you may be pushing the headphone amplifier in the player into clipping. Do you have the bass boosted? Another cause might be your headphones not being able to properly handle the bass. Have you tried using more efficient headphones?

Regarding installation of a previous firmware build:

Installing a previous version of the firmware can be performed without incident.  In fact, it’s quite useful, if difficulties are encountered with a newer build and your device.  Installing the earlier firmware is performed in exactly the same way as the new build.

Installing the earlier version is quite useful for isolating issues with your particular installation.

I recommend using the firmware files available here from SanDisk, as files sourced from elsewhere could potentially be corrupted.

One last thought: if you have the Sansa Updater installed, you can automatically reinstall the latest version at any time, since the Updater will see that your Sansa has an earlier firmware.

Bob  :smileyvery-happy:

Jk98, Thanks for your reply,

I dont think its the headphone problem since I test it with some headphones I had (Crossroad x3i, KSC75, and ATH-AD1000) and it still produce same popping/skipping sound when I push volume too high. Btw , in FM mode, I can max my volume w/o a problem :slight_smile: I’m downgrading firmware now and hope it can solve my problem while waiting new firmware .

@akleiner wrote:

Here are Links to the older Sansa Fuze Firmware Version 1.01.11:

 

For AMERICAS - Click here to download

 

For EUROPE w/o FM - Click here to download

 

For EUROPE w/ FM - Click here to download

 

For PACIFIC Region - Click here to download

 

Please use the instructions from SanDisk for updating your device on the official site:

 

http://forums.sandisk.com/sansa/board/message?board.id=sansafuse&thread.id=4880

 

 

I think downdating is on your own risk!

 

Windows Users can Connect the device in any “Mode” and follow the instructions below.

 

Mac and Linux users can connect their Fuze in MSC mode and follow the instructions below.

 

MSC mode instructions :

  • Turn on the Fuze
  • Navigate to “System Settings” on the menu of the device itself
  • Next, navigate to “USB Mode” and select “MSC”
  • Ensure your battery is > 50% full.
  • Extract the .zip file into a folder on your computer.
  • Once extracted, drag the file to the root directory of your Sansa Fuze.
  • Disconnect the Sansa Fuze and let it begin the firmware update.
  • Once it finally finishes doing its update, it will turn itself off. Turn it back on and once its back to the main menu, head to “System Settings” > “System Info”, and verify the “Version” is now 01.01.11"x".

 

Thanks for the link.  I can’t wait to get this crap firmware off of my Fuze.

I’m using my Fuze in the car mostly and have to crank it up in order to hear anything. 

I reinstalled Firmware version 11 and I’m still experiencing the popping.

Will try tonight to run with volume at 75% and crank up the volume on the radio instead.

If that doesn’t work I guess it’ll have to go back to BestBuy.

Message Edited by FrancoisA on 11-13-2008 07:06 AM