Sansa Fuze 4GB hangs after powering on


I’m having some serious trouble with my Fuze 4GB
I tried to turn it on today, it showed the initial animation but stops responding at the end of it (when the colored ‘SANSA’ logo displays).
I have resetted it many times via the power switch (holding it for 15-20 seconds), it turns off but when i turn it back on the same happens.
Please let me know if there’s another way to get it back to work.

I appreciate your help.
Thank you!

If resetting the player is no help, it only means that the files in the player is already corrupted. The only way that you could correct this is by fomatting the player which will by the way delete all the files in the player.

SOLUTION 1 - Reset the device

SOLUTION 2 - Reload and update to the latest firmware

STEP 1 - Enable MSC or Recovery mode

STEP 2 - Update to the latest firmware
You may need to upload the firmware manually, there are instructions on the links below on how to manually update your firmware.

Thanks for your help Luke2007.

I tried to set my player in MSC mode (which was already in that mode) but it still locks on the welcome screen.

My computer doesn’t even detect it so i can wipe the entire music folder.

I’m starting to think that it’s the end of it’s short life and should get a replacement…:frowning:

Once again, thanks for your help.