Sansa e260 v 2 formatted, downloaded firmware, nothing working

My husband found his sansa mp3 player after about two months in his jacket pocket. It had no battery so I went to charge it, looked like it was charging, but upon disconnect, no life at all.  Downloaded the firmware, following the version 2 directions, as it is a v2. The player showed it was “writing” after downloading.  Disconnected, and still nothing. Yes, I have formatted the player already prior to this.  I have taken the battery out, tried it in my sansa rhapsody and it works fine, I have cleaned the terminals, which is moot because we know it charged anyway since it worked in mine.  Am I missing something? I have wasted about 5 hours on this player and am wondering if I should pitch it and tell me hubby to go get the “clip” for $40…please help…

It sounds like you have done everything you can–and like the battery power just isn’t getting to the unit, which sounds like hardware troubles. You might try just leaving it connected and charging overnight and see if there’s any miraculous change, but I don’t see much hope.

And of course, you could also call 1-866-SANDISK and talk to actual tech support.