Sansa Clip won't play slotradio card

I have a new Sansa Clip+ and bought a slotradio card at Radio Shack yesterday. When I insert the card (yes, I am inserting it flush) the media refreshes; then I go to SlotRadio, click right, and then it says “Buy 1000 songs at …etc.”  And then nothing. What can I try?  I think I have tried everything.

MelloMary wrote:
I have a new Sansa Clip+ and bought a slotradio card at Radio Shack yesterday. When I insert the card (yes, I am inserting it flush) the media refreshes; then I go to SlotRadio, click right , and then it says “Buy 1000 songs at …etc.”  And then nothing. What can I try?  I think I have tried everything.

The center button is the Select button; however the music should launch regardless of which button you pushed.

Try another card from Radio Shack. You might have gotten a dud. While rare, it’s possible.

It’s also within the realm of reality that you got a defective Clip+. But it’s easier to check the card first. Do other cards work in the player?

I haven’t tried other cards as it is brand new. Maybe I’ll see if RadioShack will let me have another card.  Thanks.

Regarding my problem with the slotradio card not playing, is it possible I need to upgrade?  My SansaClip+ is v01.01.05 A.  If that might help, could you please tell me how to do that?  This is very discouraging.  I thought buying a preloaded card would solve my problems; now I may have spent $75. for a player and card and still have no music.  Thanks.

the clip+ has supported slotradio cards since its release. this is most likely a bad card. 

Did you insert the card while the player was off? If you insert a card while the player is on, it might not recognize it.

I have the exact same problem - it’s a SanDisk Sansa Fuze and the slot radio card will not appear on the main menu to actually select. It was also purchased at Radio Shack…what’s up with this? Is it the card or the player?

Does the player work properly with regular microSDHC cards?

@skuz wrote:

I have the exact same problem - it’s a SanDisk Sansa Fuze and the slot radio card will not appear on the main menu to actually select. It was also purchased at Radio Shack…what’s up with this? Is it the card or the player?

SlotRadio support on the Fuze was added in a firmware update, as it preceded the advent of the SlotRadio player and pre-recorded cards.

Is your firmware up-to-date?

Be sure to have the latest firmware installed on your Clip+, either via the Sansa Updater, or by installing manually.

If you cannot address the card:

Start with the card removed, and the Clip+ turned on.  Then carefully insert the card, and press inward to lock the card into position.  The device should respond once the card is mounted.

Let us know if there’s any activity when installing the card.

i have tested the SR and SM cards with the Clip+, both by swapping with the device OFF, and with the device ON.  The SR icon will change to the correct type of card, depending upon the type- at least, it should do so!  With the Fuze, the color of the icon also changes, pretty cool stuff.

The Clip+ has has SR / SM support since the original firmware build, but it is always a good idea to update to the latest build.

The Clip+ is version 01.02.15; for the Fuze, there are two versions depending upon the device revision.

You’ll find that SlotRadio is a lot of fun, a great deal on a big collection of music.  Its only downside is that you can’t go backwards to the previous track, but you can’t do that with radio, come to think of it.  The limitation is part of the deal with the rights holders, giving you a big collection at a reduced price.

Bob  :smileyvery-happy:

I’ve used a slotradio clip+ and the VH1Classic card a few times over the past couple months I’ve had it’ Haven’t used it for a few weeks and now when trying to read the card it gives me the described error of please buy a card, scanning / refreshing, then nothing. Checked the firmware - already at v01.02.15A as was when shipped. Says (internal) memory 3744 MB and 3444 MB free (haven’t loaded much direct yet). SD Card says 0MB and 0MB free (imagine that’s native to the preloaded / protected card). Now that I’m between 60 and 90 days - assume cannot take either the player or card back to the retailer so guess investigating warranty options. For $70 after $10 player and $10 card discounts it was great while it lasted. No way to back up the card or make it work once it goes kaput…makes it a piece of crap. I already have an IPod, MP3 player, and a smartphone…just wanted the convenience of the preloaded 1000 songs for a trip and to plug in at work. Again when it works it was good…skipped a couple times before…maybe that was the card or player going bad?

Sounds like the card has gone wonky. I’d try calling SanDisk about it. They have a 1 year warranty.

I’d telephone SanDisk, for assistance and/or warranty replacement.

In the U.S.:  1-866-SANDISK (726-3475).  And other SanDisk contact information:  http://www.sandisk.com/sandisk-support/contact-us

Great minds think alike, huh . . .  and at almost the same time too! :smileyvery-happy:

And even have consistent advise!  :wink:

And even have consistent advice!  :wink: