Sansa Clip Sport having trouble transferring music files.


I’m having a bit of trouble with a Sansa Clip Sport 8g I purchased a few months ago. Every time I try to transfer songs to the onboard memory (or external memory through the Clip), the song/songs transfer about halfway, then the player disconnects from the computer, returning the message that the directory is no longer available.

I’ve been working around the issue by using only the External memory via a 32gig micro SD, and loading the songs through a chip reader – but ideally I’d like to be able to load the songs through the player itself, and be able to use the internal memory…

In particular, loading to the ‘Music’ folder in the main directory seems to be what causes the most problem. I can move five to ten songs at a time into the root of the player (not the ‘Music’ folder) without problems, but even in the root a large number of songs or a long song/large file locks the player up. (This in particular makes it somewhat lackluster for listening to podcasts, or loading multiple albums at once…) If I try to move anything at all to the ‘Music’ folder, it crashes.

Oddly, it has no trouble when deleting large files or large amounts of songs – it’s only when writing -to- the device it has a problem…

Some additional information if it helps…

I run Windows 7 64bit. The player has also been connected to my laptop, which also runs Windows 7 64bit. I always use the eject option that Windows gives me, short of when it crashes. I’m running Firmware version 1.43. The player easily took the firmware update. Windows disc check returns no errors on the device.

I have reformatted the player through the device’s option list, and also have tried formatting the player through Windows, with no luck either time. I’ve reloaded the firmare twice. I have tried three different cables, and four different USB ports on this computer, still have the same problem.

If I move songs from the root of the device into the Music folder, it does not lock up, but I’m still having to transfer about 5 files at a time… I suppose my first key question would be – does the Sansa Clip Sport have a limitation on how many files it can transfer at once? A limit on how long of a file it can read? I’m not certain as to why it’s performing this way…

I’d appreciate any advice anyone has on this… Thanks in advance!

The problem you describe sounds to me like you are not using a micro USB cable with data transfer capability.

The micro USB cable that comes with the Sandisk Clip Sport (and all Sandisk players) has 4 internal wires; 2 for charging and 2 for data transfer.

I discovered the micro USB cable that came with my old Garmin GPS will work well with my Sandisk players. 

I have not had success with charging cables from the Dollar Store and the Five and Below store.

 I also suspected that might have been the case, along with the possibility of a bad USB port (so I tried three other ports, also) – but sadly neither of those appears to be the issue.

The three different cables I mentioned in the first post were:

  • the one that came with the Clip Sport

  • the one that came with my Fuze+

  • the one that came with my Kindle.

All of which do data transfer, and all of which I have used successfully with my Fuze+.

Thanks for looking, though – I appreciate it!