Clip Sport disconnects while transfering files

Hey guys,

So, all of a sudden, I can’t transfer music to my Clip Sport because it simply disconnects from my pc in the middle of the transfering process.

That’s it. It simply disconnects. Dragging and dropping a folder directly from Windows explorer or using and intermediary program to transfer the files (MusicBee) doesn’t matter…

It just disconnects after transfering a couple of songs and vanishes from Windows’ devices list. Then it gets stuck in the “transfering” screen until I press the power button for a while and reboot it.

Then, when I reconnect it, Windows says something like “There’s a problem with this drive. Scan it now and fix it”. However, when I scan it, it says it didn’t find any problem at all.

I’m on Windows 10 64, by the way. Latest 1.28 firmware installed. No external memory card. All previously added songs are playing just fine.

Could you give me a hand here? This really sucks. :frowning:

Thank you in advance,

Raf.

Is you computer a notebook? If so, first plug in the notebook, then connect the player. If your pc is a desktop, try using a rear usb port. The front usb ports often put out less power than the rear ones on a desktop pc. 

are you connecting the player directly, and not through a hub or usb extension cable? Did you try using a different usb cable? 

Did you ever get a solution to this?  I’ve had a new Sansa Clip Sport delivered today and have the same problem.  I can’t load anything onto it from my PC.    I own 2 earlier models, the Clip +, and they work fine with this same PC.   This new one is meant as a present for a friend.  How disappointing that the new one doesn’t work.   I cannot get any help from Sansa.

I get the most reliable connection using the micro USB cable that came with my Clip Sport.

About 4 out of 5 of my other random micro USB cables do not allow file transfers. 

Also, I am getting most reliable results using Win 10.

I tried all of these things, but none of them work. Any ideas? I don’t think stamping it to death will fix it.

(Desktop PC btw.)

Use the original cable.

I had/have similar problem.

I think computer is sending data too fast to the Sansa.

Pluggged into a USB2.0 and it seems to work OK now.

I have the identical problem with a brand new clip sport.

Using Windows 10, the original cable, & plugging it in before or after seem to make no difference.

Has anyone found a solution, or do we all own $50 mini paperweights?

Before you use your Clip Sport as a paper clip/paper weight, maybe try connecting it to your PC with each of the USB ports?

   And maybe try using a different computer?

Before you start using your Clip Sport as a paper clip and paper weight, maybe try connecting to each of the USB ports on your PC. Sometimes this works for other devices that need a bit of TLC.

Another Idea:  

Maybe try to manage the music files on your micro SD card using the SD card adapter that comes with these cards.

    I find the transfer rate with my PC is faster than using the micro USB connection to my Clip Sport.

Thank you. Not using an SD card, so that is not the problem.

Will try other ports as soon as I can drag the computer out of the corner and spend some time to get the paperweight working.

Also considering taking advantage of the “return by” offer from the retail outlet.

Everything on this computer has worked first time every time - until now.