Sansa Clip + shuts down after playing a WAV file

then I have to press the power button for 15 seconds untill I hear a “click” in my headphones, only then I can power it on again.

The problem seems to happen when I reach the end of a WAV file (my files are encoded with Steinberg’s Wave Lab directly from CDs) which means they are valid and correct WAV files, 16 bit 44khz (CD quality).

This is frustrating because I can’t listen to full quality albums without the device getting stuck after the first song.

I tried the 1.02.18 firmware update bit it didn’t solve my problem!

I even tried the RockBox firmware replacement, which totally solved the ‘shut down’ problem, but  it just doesn’t sound as good and as clean and as open and as detailed as the original SanDisk firmware.

I would appriciate any help…


I see .wav is listed as supported–

but I’m fairly sure that the Clip’s so-called .wav support is mostly for the weird low-bitrate .wav files it uses for Voice and FM recording. I remember having trouble when I tried to play standard (1411 kbps)  .wav files on it too. You might try a different encoder from Steinberg, though–maybe Steinberg does something with the header at the end. Foobar is free–don’t know if it will work or not. 

Meanwhile, the Clip will play FLAC quite well (though you have to find the FLAC files under Music/Folders since FLAC doesn’t have ID3 tags for Album/Artist etc.).

If you want lossless with the original firmware, the easiest way is to rip or convert to FLAC.  You’ll save some space, too.

Changing the firmware won’t affect the output quality of the device, aside from reducing the pitch error on some of the sandisk players.