Sansa Clip+ Set up and car volume problem

Received my Clip+ (8GB) yesterday and connected it to my laptop to charge. Very easy. Then followed instructions to drag some albums across from the HD to the Internal Memory-Music-Artist sub folder. unplugged the player to check the content and all was fine. Re-connected the player later to add more music files but the format was now different: Internal Memory folder not present. Only a Music folder showing no content allthough the player itself showed the albums are there. No Artist subfolder either. What happened? No idea. Downloaded the latest firmware and re-formatted the player, but no change. I can still drag music files to the player and the playback seems to work, too. Furthermore, there is no “Volume” control in the Settings menu. Furthermore, I bought the player for in-car use and I’m really disappointed in the very low volume through the car stereo, even at max output. Do I really have to buy an amp for the car? Not happy with the player. Can anybody help?

To comply with EU regulations, the volume output is limited on the device.  If you would like the old volume option High / Normal, under settings, use the Reset function. After resetting, choose Americas as your region, and you will once again have the “high” option.

Bob  :smileyvery-happy:

Or “Rest of World” for the volume option. 

Thanks Bob. Resetting to factory settings has done the trick. I expect the volume still to be too low for the car though. I shall try later. However, resetting the player has resulted in the content showing the Internal Memory folder again, when connected to the PC. Clicking on the Internal Memory folder reveals the Music folder (and others) but the tracks I transferred  can’t be found anywhere, although they are clearly present on the player. Any ideas what I’m doing wrong?

I suspect this is an easily-fixed USB mode connection matter.

When your player is connected to your computer under USB MSC mode (set under the player’s settings/USB Mode), your computer only sees the files that had been transferred to the player when the player was connected under MSC mode.  Likewise as to MTP mode.  Regardless, all the files show up and are playable on your player, under whatever USB mode setting.

A good reason why some people prefer to set the USB Mode on their player to either MSC or MTP:  on the Auto setting, the player tries to connect under MTP mode but then will fall back to MSC mode if the MTP connection does not work; the result being, you may have a mix of MSC and MTP mode transferred files on your player, making some of them not visible on your computer without switching to the other USB mode.  When the player is reset, the USB mode is reset to the Auto USB setting as well. 

(Because MSC mode is more universal (playing with a broader range of operating systems, including Linux and on Macs, and without a need for Windows Media Player on the computer), some people prefer MSC mode.  However, note that DRM (digital rights management) files need MTP mode–they will not transfer sufficiently (the DRM license will not transfer) under MSC mode.)

The fix for you here:  simply go into the USB setting on your player and select the setting you had used previously–your files now should appear on your computer.