sansa clip not playing music and menu scrambled.

ok.I am trying to help out a friend,he had pulled out his clip while downloading music,and seems to have scrambled it.

it does not read the menu any more,it does power up,the menu is kinda there you see lines occasionally.

It was playing music if you copied it to the music folder,But I tried doing a firmware update with the firmware updater,and now I cannot even get it to play the music,ouch!

I am wondering if there is any way to save it or is it totally gone?

best I can tell is the revision is 2.01.16

but thats what the firmware updater said,I cannot get to the menu to find it.

I also had tried a format and chkdsk.

Message Edited by slayersofadmin on 01-08-2009 02:43 PM

Message Edited by slayersofadmin on 01-08-2009 02:44 PM

Try reloading the firmware manually.

ok,I have tried manually doesnt seem to do anything,it does play the radio,but that is it.

at least I think its radio.

I dont know anything about mp3 players.

Just figured to give it a try.

I’m not sure if this will help.     Try a hard reset of the clip.    Hold the power switch in the on position for 10-15 seconds until the clip turns off.   then turn it on.       

If that doesn’t help, then try loading the firmware manually to the root level of the clip with the usb set in MSC mode.    Read over the details in the firmware post at the top of this forum

okay, i dont know how much help I can be, but I have been experiencing the same problem on my player. At first the screen was dull and you could kind of see lines, but now it is completely black. It gets stuck on shuffle mode and since I can’t see the menu I have no idea how to change it. It also gets stuck on radio mode sometimes. When this happens, here is what i do. Turn the player off and then back on. If music is not playing, then it is probably already on the menu screen. If music is playing, press the menu button and then the following sequence:


Hope this helps…