Sansa clip keeps disconnecting

When I connect it to the computer, it is recognized for a minute or so, then it randomly disconnects, only to reconnect a second later again. Is this due to a defective unit? The USB-port works fine with everything else. Also, it’s complaining that it “could perform faster if it was connected to a USB 2.0 port”, but that is exactly what I have connected it to…


1 Like

I don’t know the answer,   but i have a question:    Is there a USB hub inbetween the Clip and the computers USB port?   A couple more  Questions:   Is it a laptop computer?   Does the computer go into hybernation or sleep mode when this happens?

If it’s a desktop computer, try connection to the rear USB ports.

Maybe Someone smarter will answer your question,


No, there is no hub between the Clip and the USB port. And no, it’s not a laptop and it doesn’t go into sleep mode.

Yeah, I did try connecting to the rear ones, and it actually worked. Weird, because I have no problem connecting e.g. my external hdd to this port.

The port cant supply enough current to charge the device.

The HDD doesnt have a battery to recharge.

I had the same problem.  It turns out it was caused by using a USB cable that was not right.  I lost the one the came with the Sansa Clip.  I found another one that “fit” the port on the Clip.  Whne plugged into the powered USB port, it would say “writing” and would connect and disconnect from the PC.  I tried another cable and it would charge the Sansa Clip but did nothing else.  I notice that the end of the cable that connected to the Clip, although it fit the port, looked to be set up a little different on the inside.  I then tried another cable (this one came from my portable, external disk drive) and it worked fine - Clip connected to the PC, the PC recognized it, and everything transfered fine.  Bottomline is to make sure you are using the right cable.  Just because it will “fit” into the port on the Clip does not mean it will work.

The problem of my Sansa MP3 player disconnecting whenever I would trying to transfer data was driving me **nuts**. It would happen when I copied files directly or when I tried to add Audible audios. I read in forums that the Sansa can not keep up with rapid data transfer and so you need to switch to a USB 2 port, but that did not help me.

But I FINALLY found a solution: a USB 1 port !!!

I have a little USB combo hub card reader very similar to this one: 

In addition to reading SD chips, It has 3 USB ports, USB 1, USB2 and USB 3. If I plug the Sansa in to the USB1 port, data transfer works like a charm. 

By the way, I do not represent the company selling the device I linked to. I have no skin in this game other than wanting to help others avoid the pain I endured. If you can find another way to add a USB 1 port to your machine, I suspect it will work just as well.

If what you have is similar to the item you linked to, it isn’t a USB 1 port. It’s a USB 3.0 Card Reader and 3 Ports USB Hub, High Speed External Memory Card Reader. And that means your USB port is a USB 3.0, or that device wouldn’t work. It also means your USB port should be capable of having your Clip connected to it with a standard cable that has the same specs as the original cable supplied with it when you bought it. You can easily identify a USB 3.0 post by the plastic tab inside the connector. If it is light blue, it’s a 3.0. If it is white it’s either a USB 1.0 or 2.0.