Sansa Clip doesn't display or play files that WMP and Windows Explorer find on it

I have used the Clip happily since I first got it and managed to get it set up.  I keep a large stock of podcasts on it, and update the Clip using WMP’s synch function many times a week when the podcasts are updated.

I installed the 1.01.29 firmware update when it came out.  (From Windows Explorer it shows as 1.01.29A for some reason.) 

From that very moment, many of the podcasts I already had on the Clip, which I had listened to many times, became invisible and unplayable on the Clip.  I can, however, see them from Windows Explorer and WMP, e.g. from the Albums view.  (I don’t know why the WMP synch process puts podcasts onto the Clip as music, rather than as podcasts, but I don’t really care.)

I deleted all files, reformatted the Clip, and put the files back on.  Same story.  I also tried adding files that didn’t show/plan by dragging them to Windows Explorer.  Same story.  

The really strange thing is that it’s not random which show up and which don’t.  All the German podcasts, old and new, from two web sources, show and play fine.  All the French podcasts I had, and new ones, don’t show in the Clip’s display.  Before 1.01.29 all files from both sources showed/played fine (with one exception, which I’ll post about separately.)

Anybody else have this?  Any ideas?  I can send sample files that work and that don’t work to Sansa support if requested. 

Place the podcasts in the Podcasts folder or make sure the Genre ID tag is set to Podcast.

Yes, that works.  The podcasts that the Clip didn’t display or play as music do dispay and play when I drag them to the podcast folder in Windows Explorer.  Thanks!

I wonder why they worked fine as music prior to the v01.01.29A firmware upgrade, and why other podcasts continue to work fine as music even now.  And I can’t use the synch mechanism via WMP that Sansa doc talks about, since I see no means in WMP to direct the podcast to the Clip’s Podcast folder.  However, as long as I can download them to the Clip and play them by at least one means, I guess I’m satisfied.


I am very new to Sansa Clip

I am synchronising it with Media Monkey (new to that one too :)  and in Media Monkey it does show me songs in the Music file…I can’t find them on the player though, when I disconnect it.

I have also tried to add songs in Media Monkey directly into the ‘Music’ file instead of synchronising - the computer  shows the songs, but I can’t find them on the player.

Please- I am really very very new to this - give me advice written for dummies :) 

Thanks in advance!! 

If music files dont show on the player you probably are not using a supported music format.

It must be .mp3, .wma, .ogg, or .flac to work.

I’m having the same problem as the thread starter here.  Can someone tell me how to put the podcasts in the Podcasts folder and to set the Genre tag to Podcast? 

I put podcasts in the Clip Podcast folder using Windows Explorer.  (I do all my downloads to the Clip with Windows Explorer, since I couldn’t find anything that I actually want to do that I need the other tools for.)  While the Clip is plugged into my computer, I just copy the files (select, then Ctrl C), in whatever folder I have them in on the computer, then in My Computer click on Sansa Clip, then click on Internal Memory, then click on the Podcasts folder and paste (Ctrl V).

To change any tag before downloading to the Clip, I use the MP3tag tool.  (Just search on the internet.  It’s freeware, but you can give the guy a gift if you like it.)  After you download, install, and run it, it finds your MP3 files (you can control where it looks) and puts each on one line in its window, with a column for each tag.  Click once on the row for the file whose tag you want to change, then a second time (a second, slow, single click, not double click, which plays the file) on the specific column of the tag that you want to change for that file, and the tool opens just the tag box for editing.  You can paste text into the box from the tag of other files that have the value you want, which is a bit faster if you want to change a bunch. 

The only tag I ever change is the album title.  For some reason, a few of the sources of the podcasts I listen to have at times changed what they put in the album title, which causes the Clip to put the new podcasts in a separate subfolder, whether in Podcasts or Albums.  The folder for the old and new has exactly the same title on the Clip, which confused me till I noticed the different tag value in MP3tag.  I don’t want to go back and forth between two folders to listen to what I think of as the same podcast, so for those podcasts that have changed their album title, I take the trouble to change new to old before downloading to the Clip.

Hi again,

I am very new to Sansa and the whole concept of managing music with programms like Media Monkey, so please excuse basic questions…

I have used media monkey to set up lots of playlists and then synchronised my sansa clip. I even did it twice: once using a button on the media monkeys menu and once by doing a right mouse click on the sansa. However under music-playlists, there are no playlists.

 I tried dragging and dropping the files onto the sansa player by using explorer: i put the songs into folders and dropped those onto the sansa into ‘playlists’ but that also did not work. I can see the folders there, via explorer, but when I disconnect from my computer I can not find them via the sansa menu.

Please help :slight_smile:

Regarding Media Monkey playlists.

For this to work in MSC mode you need to:

  1. Set MSC mode

  2. Export Playlist as .m3u file and save it to the Players MUSIC folder.

Another path is to sync it in MTP mode it should work from there.

You wont find the playlists under Music / Playlists. Currently relative playlist path is not working.

But that will be fixed in the next release.

Thank you very much for your advice…Unfortunately I have a follow up:

When will the next release be? How do I export as a .m3u?



Next Clip release is today around noon PST.

To export from MM, select a playlist, right click it and find “export to .m3u playlist”. Select the place to export it to to be the Clips Driveletter/music folder

@sansafix wrote:
Next Clip release is today around noon PST.

To export from MM, select a playlist, right click it and find “export to .m3u playlist”. Select the place to export it to to be the Clips Driveletter/music folder

Excellent news! I’ll be waiting :smileyvery-happy:

Sorry, I have to bother you guys again: I still haven’t got the solution, still can’t see playlists exported from Media Monkey in my playlist folder (or in any other for that matter)

 I have downloaded the newest update but no change.

 I can see the playlists/folders in explorer but can’t find the songs (ordered in folders) on the player. Only the songs in alphabetical order/albums…

I can only synchronize in MSC mode, otherwise the computer/media monkey won’t recognise the player. And I do not know how to export in mu3 mode… PLEASE HELP 


I won’t to export playlists from media monkey to the sansa.

I have exported them as mu3 as suggested. I can see the title of the playlist in the ‘music’ folder, but its empty!

What went wrong?

PLEASE HELP, I am getting so frustrated by this player!


I tested creation and synch of playlists that I created with both Windows Media Player 11 and Media Monkey (whatever level they have out there today for free).  I’m on the latest Clip firmware level: v01.01.32A

WMP procedure:

  • create a new playlist (top left, click on “* Create Playlist,” type the name you want it to have, then right click on it and pick "Edit in list pane)
  • click on Library + Songs (or wherever you want to get your playlist content), then drag the songs to the list pane (the one on lower left)
  • save the playlist (button on bottom of list pane)
  • click on Sync on main menu bar
  • drag the playlist you created (shows under Playlists) to the list pane again, which the Sync action changed to be a pane for the Clip
  • click on the Start Sync button at the bottom of the list pane

WMP sends all the files to the Clip.  The playlist itself goes in the Playlist folder (as a .pla file, not .mu3).  You can see songs themselves in sub-folders in Albums or in Songs.  To play the playlist, just go the the Clip Playlist folder or action or whatever it’s called, click on it, click on your specific playlist, and enjoy.

 I never got into using playlists myself, but I remember when I tried it early on after getting the Clip, I noticed that if a new playlist had an mp3 that the Clip already had, WMP would download the playlist, but not the mp3 file.  I didn’t experiment with all the variants this time.

 Media Monkey procedure: (it seems to be quite a bit fancier than WMP and probably has several different ways to do anything)

  • drag the first song to the Playlist icon
  • click on New Playlist in the pop-up menu
  • give the playlist a name
  • drag other songs to the icon, but this time pick the new playlist’s name
  • find the new playlist under Playlists in the left side directory structure
  • right click it, and pick “Send to…” and then “Sansa Clip”

The playlist and the songs in it show up exactly as with WMP.

For my simple-minded dowload of podcasts to the Clip, cut & paste in Windows Explorer is just as easy as using WMP or some other tool, but for playlists, I think you need to let the tools do it, since they handle what appears to be multiple parts of the operation for you.

Hope it works for you too!

I forgot to state explicitly that the two tests worked!  I could play both the WMP and the Media Monkey playlist on the Clip.

I was a bit careless in my description above.  When you navigate on the Clip down to Playlists, then to your own playlist, it doesn’t start playing just by clicking on the playlist.  Clicking on the playlist shows the list.  You start playing it by clicking on the first song (or wherever you want to start).  The Clip plays them in sequence from that point on.

Dear Peterh,

thank you so much for your advice, its really kind of you to make time to help me.

BUT: for me, the last point on your to-do list for MM is the problem. If I ‘rightclick’ and ‘send to Sansa’ I get the sons on the player, but not the playlist. I can get them listed by artist or album but not in the playlist order…

I also tried to export as mu3. Didn’t work either -then I saw the name of the playlist, but it was empty.

Do you know what to do?

Thanks in advance!


Hi Stef,

I have two suggestions.

1a) Since I hadn’t tried creating playlists with .mp3 files that I already had on the Clip, I tried it.  It worked fine–as long as I dragged the files _ from a folder on my computer _.  It did _ not _ work if I dragged files from a Clip folder to the Media Monkey Playlist icon.  (I got no error message, but (a) when I tried to view the contents of the playlist on MM, there were no contents, and (b) when I tried the “Send to” action and “Sansa Clip,” nothing happened–I didn’t see the progress indicator at the bottom of the MM window, and when I unplugged the Clip and checked for the playlist, it was not on the Clip.  Personally I think either both steps should work or MM should give a message in both cases that there is a problem.)  This roughly matches what you see. 

Is that how you are trying to create the playlist?  If so, since you presumably have the .mp3 files on your computer, just refer to the computer’s folders and files when creating the playlist.  If you do, the “Send to” action will not download duplicate copies of the .mp3 to the Clip.  You just end up with the playlist.   

1b) However, if I have, say, three songs in playlist A and I send it and verify it’s there and playable, then I go back to Media Monkey and create another playlist B with the same three songs plus another one and send that, I find both playlists A and B, but only B has a list of songs and is playable.  The Clip now shows A as empty.  That is clearly a defect, either in the playlists work, or in the Clip or Media Monkey.  You should be able to have overlapping content in different playlists.  But I don’t think this is your problem, since you say you don’t even see the playlist name when you click on Playlists on the Clip.      

  1. If (1) is not the problem, I would reformat the Clip (and reinstall the latest firmware if possible), reinstall Media Monkey, and try again.  (But of course you still have to create your playlists from your computer’s folders.)