SANSA CLIP+ 4gb hangs/freezes on "Refreshing your media" screen when reading SD card

So I when I add files to my SD card I usually remove the SD card and place it directly in my computer so I can add/delete/move files faster. I added 4 or 5 new songs to my SD card, reinserted it into my Sansa, and booted it up. The progress bar hung at “Refreshing your media” just under the “y” in “your”. Not that this tidbit will help any, just letting you know it stopped pretty quick. So I thought maybe my SD (SanDisk brand, 16gb) card was bad, so I grabbed a new one (3C PRO brand, 16gb) and copied all my music from my hd back onto the new SD card. No such luck when booting the Sansa back on, same error. So I thought in the highly unlikely event that both SD cards were bad, I grabbed a brand-new, out-of-box 2gb SD chip (Also SanDisk brand) and formatted it to default format (FAT32) before placing it in my Sansa. Same result, and this was with a completely empty, formatted SD card I cannot browse the SD card while it is in my Sansa because it will not get past the “Refreshing your media” screen when the SD card is inserted. I have re-installed the firmware, restored factory settings, etc, etc, etc… Anyone have an idea what could be causing this? I might rockbox it pretty soon… I hate the rockboxed version because it’s so unstable, but that might work. I’ll let you know…

  1. Check your ID3 tags. Most likely there is one (or more) that is causing it to choke.
  2. There’s no reason to format a brand-new memory card. They come pre-formatted.
  3. In the event you do need to format, a 2GB card should be formatted as FAT, not FAT32.

Tapeworm, even when inserting an SD chip that has nothing on it, it still freezes at the “Refreshing your media” screen. As for Rockboxing it, Rockbox works great and reads the cards fine, except Rockbox freezes when it comes to a non-music file, such as the .sid files the clip+ put on the card, the image files that go with the albums, and the desktop.ini files. Rockbox also freezes after I skip 5 songs. Every. Time. 5 songs, whether consecutive or not. Strange behavior… Is my Clip+ toast? I was really starting to like this little thing…

Possibly corrupt formware?  You could try reapplying the firmware (see the firmware upgrade sticky thread at the top of the forum)–it couldn’t hurt? 

I have this same problem EXCEPT when the SD card is removed, then the **bleep** thing works perfectly. Looks like their last firmware update has a bug, since all was good before this.

This is my 2nd clip…and I just finally gave in and ordered an ipod due to the fact that these things seem to have issues every time I try and update my music.  I would recommend going with another device.  I love the clip…when it actually works…but that is rare.