4GB Clip+ Refreshing Media stuck self reboot and other problems.

Got Sansa Clip+ 4gb

  1. Charged via USB to 100%

  2. Transfered an album

  3. Listened to album

  4. Turned off

  5. Inserted 32gb class 4 SDHC card (no data)

  6. Wouldn’t turned on with 32gb card in there

  7. Thought I’d try putting it in while it’s switched on.

  8. Stuck on refreshing media 1/10 of the way

  9. Turned itself off (at least I thought it did) (unresponsive with no screen display)

  10. Took out 32gb card

  11. It turned itself back on (still on refreshing your media., without card in there)

  12. “Oh crap it’s still on”

  13. Turned it off.

15 Put card in and turned on.

  1. Still on refreshing your data, except now it 1/5 of the way.

  2. Refreshing your data didn’t move at all for 15+minutes

  3. Turned off

19, Took out 32gb

  1. Connected usb, the album I transfered initially to player was gone, as well as the 6 songs that were preinstalled.

  2. Tried to reformat it with card and format failed

  3. Won’t turn on with card in

  4. Card out, it loads “Sansa” > “Sansa logo” > Refreshing your media, all 3 FAST! Then REBOOTS and repeats, but stays on refreshing media.

32gb card works fine, transfering music to it now on my 3g USB Wireless stick.

Both the player and card is new.

Have got “Need to format to use error” (tried to format with card in, but just got “4.03mb” data size :S

Have not updated it with the time for protected files thing (had no internet at the time on my laptop)

Have I tottaly bricked my player already, because I took the card out and also put it in, whilst it was still on?

Is my only bet, wait for battery to die, or install rockbox?

TRIED:

A. Soft reset (thousand times)

B. 32gb card in and out a few times.

C. Formating Fat32 (32gb card doesn’t even show up on drives in explorer whilst it’s in the sansa clip+, had to do on usb stick)

I’ve only got access to the internet now, unfortunately though, brought headphones and the player but forgot the USB wire, doh! But I have read through a couple of posts of similar problems, but found none mentioning where it:

  • boots fast to refreshing your media, reboots and repeats except at normal speed, staying on refreshing your media.

It doesn’t say “goodbye” any more either, I also can’t turn it back on for a few minutes when do a soft reset.

It sometimes flashes the UI when turn on, but it’s just a flash, maybe even more of skewed glitch, I don’t know it’s too fast.

I don’t understand why it wouldn’t turn on with the 32gb card (card works fine, and is new).

Nor do I understand why it said refreshing your media when I had no data on the new 32gb card!

Any one have any experience with this particular situation?