Sansa Clip 2GB will not read music from SDHC card

I have been fooling around with a friend’s Sansa Clip for the past few hours. She only has a 2GB player but just over 3GB of music so I decided to use a 16GB SDHC card I had lying around. 

At first, I decided to just throw music on the card via my card reader. The player couldn’t see the music but did recognize the card. I have tried numerous different variations of putting the music straight onto the card, a fresh format before each attempt.  Also, I made sure to run the windows error checking utility on the card itself to check it for filesystem errors, which came back clean.  I have changed the ID3 tags as my research into this problem has suggested. I have tried putting the device into MSC and MTP modes, each coming to the same problem. I have attempted putting the music onto the card with it plugged into the player while in MSC and also MTP using windows explorer. I have tried to use Media Player to transfer the music in MTP mode. Nothing I have tried has worked. In fact, I have run into some, in my opinion, pretty interesting problems.

If the device is set to MSC and the card is in the player, my computer asks me to format the drive when I plug it in. I have attempted to format, yet it shows no information on the drive itself. If I attempt the format anyway, I instantly get a dialog box telling me Windows cannot format the drive. If I attempt to enter the drive through explorer it tells me to insert disc. If I use my card reader to view the contents of the card, there are no problems. I have full read/write access, etc etc. I have used SDFormatter to format the card, so I know it doesn’t need to be formatted.

If the device is in MTP and the card is in the player, explorer shows me two entries under Sansa Clip; Internal Memory and External uSD card. Through explorer I have read access to both the internal memory and the SD card. If I attempt to drag/drop a file to the card via explorer it tells me “You do not have permission to create this item.” If I try to use Media Player to transfer files to the card it errors out and tells me “Windows Media Player cannot access the file. The file might be in use, you might not have access to the computer where the file is stored, or your proxy settings might not be correct.” 

The device is up to date with the latest firmware and I just don’t understand what in the name of God is going wrong here. I have transferred a few sample files into internal memory just to troubleshoot the files as being the problem and they work flawlessly when in internal memory. 

I have put music files onto the card and tried using it in my Android phone and it reads and plays flawlessly, so I would assume that rules out a bad card.

What am I missing and is there anything else I can do? I’m almost ready to set fire to this thing!

Bueller…

Bueller?

You might try reformatting the card using the SD  Association’s formatting tool–that sometimes can help.

https://www.sdcard.org/downloads/formatter_3/

That is the program I used to format after each attempt.  No-go.

I wonder if there’s a problem with the player, itself. Perhaps some microprocessor in charge of managing your card has malfunctioned? Or, it could be a weird glitch in your firmware, in which case, manually reinstalling the firmware might help.

This really is a headscratcher.

Is this a class 10 card? Sandisk players have issues with some class 10 cards. Try using a class 4 card. Use MSC mode.