SanDisk Ultra, Windows 8.1 Compatibility ?


I have a sandisk ultra usb flash drive (SDCZ45-032G) that works perfectly on windows xp and windows 7 computers but doesn’t work on any windows 8.1 computers.

When plugged into a windows 8 computer, it just flashes. and in “my computer” it shows up but it doesn’t show the size…etc and I’m unable to open it without getting an error.

I’ve tried reassigning a new drive letter and trying the steps in this link:

I’ve also tried doing a low level format and then doing a full format on a windows 7 pc but it doesn’t make any difference.

Is this a known window 8 compatibility problem ? 

Quick update:

I remembered that i bought 2 of these exact same pen drives, so i just tried the other one and it giving me the exact same problems so we know its not a faulty pen drive.

Its strange because the other one works perfectly on a windows xp and widows 7 computer as well.

On the Windows 8 machine try using a USB 2.x port.  See if that helps.

Thanks for the reply.

I’ve tried both usb 1.0 and 2.0 ports, I’ve even tried using a hub but i get the same problem with all of them :frowning:

A Windows 8 machine with USB 1.0 ports!!

Regardless, it could be a Windows 8 security issue, not allowing removable drives.  Do other USB drives work in the Windows 8 machine?

Yeah i put in an old usb 1.0 pc card i had just to check…lol

All other flash drives work perfectly fine .

Are the other flash drives seen as Removable drives?  Is the SanDisk one seen as Removable? 

i have the same drive and it works on my toshiba laptop, my Surface Pro, and my custom build desktop all running 8.1 so I don’t think this is a Win 8 compatiblity issue. 

Thanks for all the replies.

I went out and bought a 32gb lexar jumpdrive today and it works perfectly on all the computers and all the ports on the windows 8.1 computer.

I would put it down to the sandisk drive just being faulty but that wouldn’t explain why it works on every other computer i plug it in to and why my other other sandisk drive (same model) has the same problem.


Are there any files on the new Lexar drive?  Executable types.  Are there any files, executable types, on the SanDisk drives?

It could be the security apps on your Win 8 machine are preventing the drive from being accessed due to a false positive.

Yes, this is definately a Microsoft incompatibility issue. I too have an almost new Sandisk Cruzer Blade 8GB stick that works on ALL machines except Windows 8.1

Another issue that MS seems to want to pretend doesn’t exist.

Did you try to boot from the Ultra on that PC?

This way Windows is out of the picture.

(you have to record something bootable on the key before, of course)

One other thing is to boot Linux on that PC and try to use the USB key.

I have the same issue with my new SanDisk Ultra 32GB USB 3.0.

This machine boots both Windows 7 and Windows 8.1, the drive reads fine in Windows 7, reboot into 8.1 and it sows up in Device Manager as “Unknown USB Device (Invalid Device Descriptor)”  and reports an error code 43 to the same effect.

I was hoping by now somebody had solved this.