SanDisk Ultra USB 3.0 Flash Drive 64 GB - Unable to save certain JPG files

Hi Guys,

I have a SanDisk Ultra USB 3.0 Flash Drive 64 GB. Currently it has about 20% of the memory used.

I have received pictures from 2 different photosessions from the same photographer. All pictures appear to be JPG type. They range from 5 to 25 MB. The size of the first photosession is around 5 GB (contains one folder). The size of the second photosession is around 20 GB (contains 6 folders).

I was able to save only the pictures from the first photosession for some reason. When I copy the pictures from the second photosession all in one go or one by one I see the folders/file names saved on the flash drive but when I click to open any picture nothing happens. The size of the used memory has increased by 25 GB, however I am able to open only pictures from the first photosession.

I am also able to save and open other file types like Doc and pictures from Iphone etc.

I formatted the flash drive once already, however when I copied all the photos back to the drive I was able to open all of them except any from the second photosession.

Please help to resolve this mystery!

Thank you very much!

It sounds like the flash drive can save the pictures, "The size of the used memory has increased by 25 GB, " so the problem isn’t a storage problem.  Without knowing what OS you are running, what app you are using to view the pictures, what format you formated the drive to, or any error msgs you are getting it’s hard to say what the problem is but I suspect it’s your antivirus app causing the problem.

Hi Ed_P,

Thanks for looking into my issue.

Exactly, it looks like the pictures have been saved on the flash drive as the memory usage went up significantly.

I am running MacOS High Sierra 10.13.5. 

I view the pictures with standard Apple ‘Preview’ program.

I formatted the flash drive using these instructions:

I am not getting any error messsages when I try opening pictures. Once I double click on the picture it shows a thinking wheel for 1- 2 seconds and then it dissapears and nothing happens. The thinking wheel is not a typical rainbow colour Mac wheel but the greyish one.

I have recently installed malwarebytes app.

Should I try removing malwarebytes app?

I just tried removing malwarebytes app from the system. Restarted my computer and tried again. Unfortunately I am still unable to open those pics…

Sorry Bhee5 I am not a Mac person.  I can’t help you.