Sandisk Ultra Backup 16GB not showing up on computer AT ALL

Hi all,

I have a Sandisk Ultra Backup 16 GB, and it’s worked like a charm - until recently. As of a few days ago, whenever I plug the device into my computer it doesn’t show up AT ALL. Not on device manager, not in ‘Devices with Removable Storge’, no nothing. So far I’ve tried plugging it other USB ports, all to no avail. I also plugged it into my laptop, but even my laptop doesn’t recognize it. The orange light on the device glows, but it isn’t recognized by any of my computers. As far as I know, I didn’t do anything to it. I just plugged it into my computer one day and it didn’t show up on the computer. 

Two possibilities that I can think of:

  1. The device is woren out.

Maybe, m a y b e, cleaning the contacts of the USB drvice with a small piece of emery paper might give it enough life that you can backup your files on it to your hard drive.

  1. Another USB device was used and it was assigned the drive letter normally assigned to your USB drive and it’s driver is incompatible with your USB device.

Maybe, if you reinsert the other USB device and manually assign it another drive letter when the Sandisk drive is inserted it will work.