SanDisk UltraFlair USB 3.0 64GB not showing up on my laptop

My newly bought USB stop showing up on my laptop ever since I used it for the first time. I was transferring files to my laptop (window 10) and after a while, it says that my USB is running out of space which is not true considering the files I transfer are only 50+ GB while the USB is supposed to have 64GB space. After that, my USB just disappear from the laptop. I tried plugging the USB on different USB ports and different laptops, it does not show up as well. I could not find the USB in the device manager and disk management too. I have tried everything I know, need help now. Thanks!!

Hi, you can first try to check the compatibility of USB port and device. then apply this following steps to find the USB in disk manager>Enable flash drive in BIOS setup>Update disk driver> Format the flash drive to eliminate virus>Repair bad sectors on flash drive.
Thanku

I couldnt find my usb in BIOS setup, i have plugged in my usb

1 Like

Unplug the USB drive, reboot the system, plug the USB drive back in. Does it show in Disk Management? Does it have a drive letter? If not assign one. Run a chkdsk command for the drive. If you are unable to run a chkdsk command for the drive return it to the seller for a replacement.

it doesn’t show in disk management sadly :frowning:

Try a different USB port, try a different computer. If it fails to show return it to the seller for a replacement. Or return it to SanDisk for a replacement but doing so takes longer.

Tried both before, doesnt work, guess i will have to bear with the loss since i bought it through tesco online delivery

SanDisk replacements are free. They just take time.

Return Material Authorization (RMA) process (sandisk.com)

Hi, try to contact to the customer care support.thanku