Sandisk Ultra 64gb MicroSD Wont format.

Same here, what a drama - just bought a SanDisk microSDXC UHS-1 64GB with adapter.

No way I can format it under Windows 7 x64.

Seems there is no solution for this.


I had a problem with a 64 GB SDXC card yesterday. It’s capacity showed as “1 MB” on all devices and showed both “NO SD” and “SD ERR” in my GoPro Hero 3+ Black (v3.0.0). I tried formatting using a computer (Win 8) with diskpart.exe as well as other reformat tools. No luck. I then plugged it back into my GoPro and tried reformatting it on there (settings>erase>erase all/format). This seemed to fix the problem and it now recognized it as a 64GB card on my devices and functions normally. 

That said, there seems to be no way to recover any data on the card. This needs to be addressed by SanDisk however I have not yet gone through the hassle of contacting them. 

I had the same problem as everyone else here on the forum. Nothing worked but this.

You have to format the card using Windows Command level option;

  1. Run and type “cmd”

  2. Then type; “format L:”

  3. Get a cup pf coffee and relax


** L = your sd card drive letter

** don’t use quotation marks

** there is a space between format and the drive letter

Yes, I have the same problem! When i try to format sd card after this all data is stayng on the disc :stuck_out_tongue:

Please Help ! 

I was able to format my card eventually…

I had searched and tried many ways including formatting via command prompt, formatting through my android and formatting through windows.

When trying to format with windows it would only give me the option to format it at 27gig.

In my android device it said that it successfully formatted and appeared to 64gig. however when connecting to USB in window it was still only 27gig. 

I finally got it to format using the DJI OSMO UHD camera whilst connected to a USB port with Windows 7. upon connecting to windows through the camera, windows prompted me to format it and it allowed the full 64gig to be formatted… That’s it!

I hope it helps someone out as I was almost going to try and get sandisk to replace it.

Good luck!