Sandisk Ultra 32GB micro SD card - can't format and can't be recognize

Hi Everyone

I got a ORIGINAL Sandisk Ultra 32GB micro SD card for my Samsung Galaxy S3. It’s a original one, bought at BestBuy in late 2012. Everything was fine, then I noticed a message saying my card was blank and needed to be formatted. I couldn’t format it 'coz I got all the photos from my trip and from my job on that card. So, I tried to backup it up and got no luck. Tried to access it from Windows and no luck either (asks all the time for formatting it). So, I don’t freaking care about that muthafu**er card, I just want my data back! 

Then, there comes my question: Sandisk, how can you repair me from losing most of my family and job photos? And please, do not waste your freakin time saying that I shoud have backed 'em up, 'coz believe me, if I had had the chance I obviously should had done it.

So now, I don’t want another card, I don’t want a house full of gold, I just want my fu**ing data back! 

I used to buy everything from Sandisk, 'coz I thought their products were one of the best in market (excelente quality, trusted reliability - even being more expensive) but from now on, Sandisk never again. And the funny part is that I use a Sandisk SSD as a backup Hard Drive. So, I’m in a real dangerous situation.