Sandisk Ultra 16GB chage Sandisk Anisha 64MB and Unformatted

Please help me

My sandisk ultra 16GB chage sandisk Ansiha 64MB and unformatted :frowning:

What should i do? IMG_20160417_212252.jpg

You could try running CHKDSK on it.  You could try Safely Removing it, rebooting your pc then retrying the USB drive.  You could try it in a different pc. 

If there are no files on it that you want to save you could try reformatting it.

Exact same issue. Tried uninstalling drivers, cleaning the driver throiugh cmd, formating it in disk manager. Tried using roofus, boot into linux mint and tried the disk management on there, nothing. Is there no tool to fix this?

I just started having this same issue with a Sandisk Ultra USB 3.0 16GB drive. Appears as “SanDisk Anisha Media” with a capacity of 67.1 GB.   I have tried reformating and repartitioning, on both a Windows 7 PC and a MacOS 10.11 iMac. No luck with either. I ran Disk Utility and the program just locks up while trying to erase the drive.

There is no solution in this thread. Does anyone have any ideas? Has the drive failed?

“Has the drive failed?”

Maybe.  Try returning it for a replacement.

http://kb.sandisk.com/app/answers/detail/a_id/5232/~/return-material-authorization-(rma)-process