SanDisk SSD Dashboard Does Not Recognize Extreme Pro 480GB

Installed new Extreme Pro 480GB SSD drive last week. Installed SanDisk SSD Dashboard (1.2.0) today and it does not recognize the SSD drive. No information is displayed when the application starts up. I’ve rebooted the PC and ran the application as administrator. I’m using Windows 7 64 bit.

Any assistance would be appreciated before I uninstall this application.

Can you run msinfo32 (from program files->run) and export to a file.

Send the file through private messages.



Please check in the device manager how the drive is showing up like a ATA device or SCSI device. If the drive is as SCSI then its not detected because the sata commands do not pass through the controller of the ssd and so the os with the dashboard does not see the ssd in the system.

For now if thats the case you cannot do much but sandisk states that they will fix this with the new version of the dashboard

Sorry for the delayed reply.

Device Manager does show it as a SCSI device for some reason.

I had SanDisk support contact me via email and they had me change a registry setting and then rebooted the PC, went into setup and in the BIOS I changed the setting under “Sata Controller Mode” and changed the setting from “RAID” to “AHCI”. Saved the configuration, exited the setup so the PC would restart and the Windows 7 OS would not come up, it Went into Startup Repair mode where the system attempted to repair itself but was unable to do so. Rebooted and tried again with same results. I changed my BIOS setting back and was able to get into the Windows System Restore and this changed my regedit setting back and the PC was then able to boot up again.

If I would have not been able to initiate a restore to a previous time I’m guessing that I would have been stuck restoring my PC to its original factory settings.

If SanDisk is saying that this will be resolved in a future version I’ll just un-install this version of the Dashboard and will check back periodically.

Georgealon, if you have any other ideas and still need the msinfo32 information, please let me know how to send a private message and I can get that info to you.

Thanks for the assistance.


I was going to check your device connection, but it looks like you were contacted and you already know the answer.

Unfortunatly, we do have some issues with RAID and SCSI connection. Please try the latest version 1.3.0 released yesterday.



Thank you for the prompt reply.

I just updated to the 1.3.0 version and the Dashboard still doesn’t recognize my SanDisk SSD.


thats a pity that sandisk did not fix the scsi drive issue in order the dashboard detect these drives also.

I just read the fact that you changed the sata configuration from RAID to AHCI when you already had installed the os, that was a bad idea and i would never recommend that to anyone. If you change the configuration of the sata connection all the command lines that are send from the motherboard (controller) to the OS are lost so the whole configuration in the registry of the windows that was the hardware installed is invalid.

The only think you can do if u want to change the bios settings is to do before an installation.