Version still not recognizing SSDs

You guys really need to get a handle on this as I see the complaint below about version having this exact problem and that is closing in on two months old.

I hadn’t run the dashboard in awhile so I let it “upgrade” to version today which completely broke the dashboard for my Windows 7 Home 64 bit install.

Sandisk Dashboard I don't think so.jpg

So I downloaded version and AMAZING!  It works just fine.  Seriously you guys need to disable the notification for a new application if that is simply going to take you from working just fine to completely broken until you guys get a handle on the problem…

Sandisk Dashboard Hey look it works.jpg

Can you screen capture the System Details under the Tools section. I think this will help to understand the environment this is happening in.  Thank you.

I have exactly the same issue on Win 7 64 bit Home edition. No SSD found since updating to today. Going back to

Can you screen capture the System Details under the Tools section. I think this will help to understand the environment this is happening in.  Thank you.

You can do this from your version and it will help out the developers.  Are you connected wirelessly? I see an issue in another forum with the latest version and wireless.

Check if your SATA drivers are uptodate, I had the same problem and it was because of the SATA driver.

The same problem by version

Version is OK.

You could try to use the “Standard SATA-AHCI Controller” Driver instead of the Specific driver for your Board.

If THAT works, then look if your Installed Board Driver for the SATA are realy the latest…

If you have an optane memory module, you will have to disable it for dashboard to see the ssd.  I prefer to enable optane and hope dashboard will be upgraded someday to recognize modern computer systems.


I have the same issue (I think).  I just replaced and removed my old C drive in Windows 10 with a new Sandisk SSD Plus 480GB.  The drive appears to be working correctly, as I have booted into windows and I am typing this message on the machine that has the new Sandisk drive, but the Sandisk SSD Dashboard ( is reporting that “Sandisk SSD not detected”.

I have attached a screenshot.

Any ideas?



Do you have an optane Memory enabled?


I am running an AMD system, so no optane…



Did you get the latest CERTIFIED SATA drivers from your Board Manufatuer, or try the Windows STANDARD SATA drivers, an see if it then works.

I Had the problem with my SSD Plus, an in my chase it was that the AMD Sata drivers where out of date, an there was an problem with updating the drivers, I had to COMPLETLY remove the AMD Sata drivers to Instll the Uptodate AMD Sata drivers.

Thanks for the information :slight_smile: I will give this a try at the weekend.  It could be that the SATA drivers are quite old… :slight_smile:

I had the same problem on No AMD or funky memory, didn’t bother to check my drivers, I don’t want to mess with what works.

What finally solved it for me: I had Windows 10 Ransomware Protection enabled with Protected Folders (Documents, Pictures, Music, Desktop,…).

Allowing the SSD Dashboard (“Allow an app through controlled folder acccess”) resolved the problem for me, even though I am not happy with that solution.

I guess there is a bug in the error handling of SSD Dashboard. In my opinion, it has no business writing there.

Hi degerrit,

Other than the folders you listed (Documents, Pictures, Music, Desktop), did you have any other folders protected by the Ransomware Protection? Most of SSD Dashboard’s writing should be in the directory in which it’s installed. We would appreciate any additional info you’re willing to provide!

information about ransomware and how you can remove it. In fact, I have given you my own decrypter to recover your files from  ransomware. I have told you all the possible methods to remove ransomware. Now it depends upon your luck if you are able to recover your files or not.

Download removals tools free